Testing de XPlorer

Llevo casi un año y medio trabajando de forma más o menos constante en el desarrollo de XPlorer.

XPlorer es un sustituto gratuito para el Explorador de Windows con soporte multipestaña, y algunas funcionalidades avanzadas.

En este tiempo he podido implementar nuevas funcionalidades, mejorar la accesibilidad de las opciones básicas, mejorar el rendimiento general de la aplicación, y detectar multitud de errores y problemas de estabilidad.

A pesar de que el desarrollo se ha alargado más de lo deseable, XPlorer está apunto de entrar en fase beta, por lo que os agradecería muchísimo vuestra ayuda. Lo ideal sería comenzar el ciclo beta con la mínima cantidad de problemas y errores, así que agradecería vuestros reportes al respecto.

Cuanto más detallados sean estos informes, mejor que mejor. Un formato conveniente sería:

Versión de XPlorer
0.40.113

Descripción del problema
Se cuelga al acceder a determinadas carpetas FAT16.

Hardware y software
AMD Ahtlon XP 2400+ con 1024 Mb de RAM corriendo Windows XP SP2 con permisos de administrador.
Discos duros C: Seagate UDMA-133 de 80 Gb, y D: Seagate UDMA-133 de 60 Gb.
[Más información en caso de aplicarse al problema]

Con vuestros comentarios, espero ser capaz de reproducir el problema, para corregirlo lo antes posible.

– Página oficial: https://nikkhokkho.sourceforge.io/static.php?page=XPlorer
– Descarga (ZIP): https://nikkhokkho.sourceforge.io/images/XPlorer.zip
– Descarga (Instalador EXE): https://nikkhokkho.sourceforge.io/images/Setup.exe

Las sugerencias son también bienvenidas, pero de momento solamente serán agregadas en el roadmap.

Muchas gracias.



17 comentarios en “Testing de XPlorer”

  1. Gracias por los ánimos

    Estoy considerando si liberaré el código o no, aunque lo veo difícil, como se indica en la ayuda, depende de componentes VCL de terceros, que he tenido que modificar, por lo que esos componentes no serían liberables. Sin los componentes modificados, el programa , ni siquiera compilaría.

    Independientemente de que sea código abierto o no, puedes usarlo, revisarlo, copiarlo, enviar sugerencias, venderlo, …

  2. Tiene muy buena pinta, pero la pregunta es tu proyecto es de codigo abierto?? para poder seguir revisandolo y poder sugerir mejoras …?

  3. Scailay, he instalado BSPlayer 1.36.825, y me abre los videos correctamente.

    Tanto con doble clic, como con ENTER, como con botón derecho->System menu->Abrir.

    ¿Alguna pista más?

    Carlos, imagino que en tu equipo has cambiado la configuración de colores a personalizada, ya que con los colores por defecto, en cualquier versión de Windows las pestañas son grises.

    Puedes probar con una combinación de colores por defecto a ver si se arregla? ¿Puedes mandarme un pantallazo para verlo?

  4. Un detalle. Las pestañas (todas) me salen en color azul, color de seleccionado. ¿No sería más lógico que las pestañas no seleccionadas estén en gris? O, si no fuera posible, yo preferiría que estubiesen en gris en vez de en azul. ¿O no es normal y sólo se ve así en mi equipo?

  5. Confirmo que el error "'1919.067' is not a valid integer value" ya no sale. Felicidades 🙂

    En cuanto a las unidades de red, en el trabajo tengo varias y navego sin problemas por ellas…

  6. La opción de autorefrescar, será una preferencia que se podrá configurar en la siguiente versión. Aunque por defecto se comportará como hasta ahora, para dar un mejor rendimiento en máquinas poco potentes, o tratando con muchos archivos.

    El problema de las conexiones de red, tendré que estudiarlo con más detenimiento a ver que puede estar pasando.

    Cualquier otro reporte más, será muy bienvenido.

    Muchas gracias.

  7. Hola Guti
    excelente el xplorer, lo descargué ayer y lo he estado probando, ya de entrada tiene muy buena presentación y además muchas utilidades que estan al alcance de un click, felicitaciones.
    Uno de los problemas que descubri ayer fue que cuando haces operaciones en las carpetas, ya sea pegar o eliminar, estas no se actualizan, hay que darle un F5 para que lo haga, cosa pequeña pero importante.
    Otro problema que encontre: yo tengo un enlace permanente con una unidad compartida en otro pc el cual se llama \publico en XMAQUINA, cuando hago click sobre esa conexion el explorador de windows abre esa carpeta y muestra el contenido en cambio xplorer me arroja el mensaje "Funcion Incorrecta".
    En todo caso, si aparece algo más estoy posteando.
    Un saludo cordial y nuevamente felicitaciones por tu programa.
    Luis Vasquez.

  8. Por si sirve de ayuda (supongo que a estas alturas ya no) yo también me he encontrado con el mismo error que Scailay con un archivo de 1.919.067 KB pero que no es de vídeo, es un .tgz.

    Versión de XPlorer
    0.40.103

    Descripción del problema
    Al seleccionar un archivo de 1.919.067 KB me salta un error:
    "'1919.067' is not a valid integer value"

    Hardware y software
    Pentium 4; 512 MB; WXP SP2
    C: 74 GB, NTFS

  9. Pues ya lo estoy probando y si encuentro algún error te lo diré.

    Por ahora, sí te puedo decir que tiene muy buena pinta.

    Un saludo.

  10. Versión de XPlorer
    0.40.103

    Descripción del problema
    Al seleccionar un archivo vídeo en me salta un error:
    "'1433.454' is not a valid integer value"

    Lo curioso es que no me pasa con todos. Lo que si ocurre es que no puedo lanzar el reproductor de vídeo desde el XPlorer (BSPlayer) en ningún caso.

    [bHardware y software
    AMD Athlon K7 1 GHz; 512 MB; WXP SP1
    C: Seagate 40 GB 7200 rpm (ahora no recuerdo el modelo)

Deja un comentario