﻿<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="es">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Uptime 2 para DOS | Bitácora de Javier Gutiérrez Chamorro (Guti) </title>
<meta name="dc.title" content="Uptime 2 para DOS | Bitácora de Javier Gutiérrez Chamorro (Guti) "/>
<meta name="dc.subject" content="guti, nikkho, weblog, blog, bitácora, javier gutiérrez chamorro, javier gutiérrez, javier, gutiérrez, chamorro, diario, reflexión, reflexiones, crónica, crónicas, artículo, artículos, relato, relatos, opinión, opiniones, noticia, noticias, j.g.ch, jgch, j.g.c, jgc, j.g, jg"/>
<meta name="dc.description" content="Mi nombre es Javier Gutiérrez Chamorro (Guti). Tengo 41 años, y también se me conoce por Guti o Nikkho. Los que seáis fieles a este blog podréis ir leyendo desde aquí mis reflexiones a modo de crónica sobre varios temas de mi interés. Si te gusta la tecnología, la informática, la programación, los coches, o la filosofía, entre otras cosas, seguramente encontrarás extremadamente atrayente este sitio."/>
<meta name="author" content="Javier Gutiérrez Chamorro (Guti)"/>
<meta name="dc.creator" content="Javier Gutiérrez Chamorro (Guti)"/>
<meta name="dc.type" content="weblog"/>
<meta name="dc.type" content="blog"/>
<meta name="resource-type" content="document"/>
<meta name="dc.format" scheme="IMT" content="text/html"/>
<meta name="dc.source" scheme="URI" content="http://www.javiergutierrezchamorro.com"/>
<meta name="dc.language" scheme="RFC1766" content="es"/>
<meta http-equiv="Content-Language" content="es"/>
<meta name="dc.coverage" content="global"/>
<meta name="distribution" content="GLOBAL"/>
<meta name="dc.rights" content="Creative Commons (cc) 2004-2017 Javier Gutiérrez Chamorro (Guti)"/>
<meta name="copyright" content="Creative Commons (cc) 2004-2017 Javier Gutiérrez Chamorro (Guti)"/>
<meta name="robots" content="ALL,INDEX,FOLLOW,ARCHIVE"/>
<meta name="revisit-after" content="1 days"/>
<meta name="ICBM" content="041.42578, 002.186203"/>
<meta name="apple-mobile-web-app-capable" content="yes"/>
<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=0.1, maximum-scale=10, user-scalable=yes"/>
<link rel="alternate" type="application/x-opera-widgets" title="Bitácora de Javier Gutiérrez Chamorro (Guti)" href="https://widgets.opera.com/widgetize/Feed%20Reader/Advanced/?serve&amp;skin=skin6&amp;widgetname=Bit%C3%A1cora%20de%20Javier%20Guti%C3%A9rrez%20Chamorro%20%28Guti%29&amp;url=http%3A%2F%2Ffeeds.feedburner.com%2Fjaviergutierrezchamorro&amp;rel=myopera&amp;ref="/>
<link rel="alternate" type="application/rss+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) RSS Feed" href="http://www.javiergutierrezchamorro.com/feed/rss"/>
<link rel="alternate" type="application/atom+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) Atom Feed" href="http://www.javiergutierrezchamorro.com/feed/atom"/>
<link rel="alternate" type="application/rss+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) RDF Feed" href="http://www.javiergutierrezchamorro.com/feed/rdf"/>
<link rel="alternate" type="application/rss+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) RSS Feed de los comentarios" href="http://www.javiergutierrezchamorro.com/comments/feed/"/>
<link rel="pingback" href="http://www.javiergutierrezchamorro.com/xmlrpc.php"/>
<link rel="shortcut icon" href="http://www.javiergutierrezchamorro.com/wp-content/themes/guti/favicon.ico"/>
 
<link rel="canonical" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138"/>
<link rel="publisher" href="https://plus.google.com/108304469897790042618/posts"/>
<meta property="og:locale" content="es_ES"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Uptime 2 para DOS | Bitácora de Javier Gutiérrez Chamorro (Guti)"/>
<meta property="og:description" content="No hace mucho que os hablaba de Uptime para DOS, y que publiqué la versión 1.00 y la 1.10, un sencillo programa escrito en FAST, y que replicaba el comando uptime de UNIX. El desarrollo empezó muy bien, con una eficiencia casi de ensamblador, pero contando con la ventaja de las estructuras de alto nivel. &hellip;"/>
<meta property="og:url" content="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138"/>
<meta property="og:site_name" content="Bitácora de Javier Gutiérrez Chamorro (Guti)"/>
<meta property="article:publisher" content="https://www.facebook.com/javier.gutierrez.chamorro"/>
<meta property="article:section" content="Informática"/>
<meta property="article:published_time" content="2017-08-04T11:31:21+02:00"/>
<meta property="article:modified_time" content="2017-06-08T10:54:38+02:00"/>
<meta property="og:updated_time" content="2017-06-08T10:54:38+02:00"/>
<meta property="fb:app_id" content="254712291385660"/>
<meta property="og:image" content="http://www.javiergutierrezchamorro.com/wp-content/uploads/2017/08/uptime_2.png"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:description" content="No hace mucho que os hablaba de Uptime para DOS, y que publiqué la versión 1.00 y la 1.10, un sencillo programa escrito en FAST, y que replicaba el comando uptime de UNIX. El desarrollo empezó muy bien, con una eficiencia casi de ensamblador, pero contando con la ventaja de las estructuras de alto nivel. [&hellip;]"/>
<meta name="twitter:title" content="Uptime 2 para DOS | Bitácora de Javier Gutiérrez Chamorro (Guti)"/>
<meta name="twitter:site" content="@bitacoraguti"/>
<meta name="twitter:image" content="http://www.javiergutierrezchamorro.com/wp-content/uploads/2017/08/uptime_2.png"/>
<meta name="twitter:creator" content="@bitacoraguti"/>
 
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="stylesheet" href="http://www.javiergutierrezchamorro.com/wp-content/themes/guti/style.css"/>
<link rel="stylesheet" href="http://www.javiergutierrezchamorro.com/wp-content/themes/guti/options/side-green.css"/>
<link rel="stylesheet" href="http://www.javiergutierrezchamorro.com/wp-content/themes/guti/options/content-white.css"/>
<style type="text/css">#header-wrap{background:transparent url("http://www.javiergutierrezchamorro.com/wp-content/uploads/header-fire-green.jpg") repeat center top;}.block-content{width:95%;max-width:95%;}#pagetitle{font-size:75%;}</style>
<!--[if lte IE 6]>
<style type="text/css" media="screen">
 @import "http://www.javiergutierrezchamorro.com/wp-content/themes/guti/ie6.css";
</style>
<![endif]-->
<link rel="alternate" type="application/rss+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) &raquo; Uptime 2 para DOS RSS de los comentarios" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138/feed"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.javiergutierrezchamorro.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='simple-payments-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/modules/simple-payments/simple-payments.css?ver=4.8.1' type='text/css' media='all'/>
<link rel='stylesheet' id='front-estilos-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/asesor-cookies-para-la-ley-en-espana/html/front/estilos.css?ver=4.8.1' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-postratings-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.84' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-pagenavi-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-syntax-css-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-syntax/css/wp-syntax.css?ver=1.1' type='text/css' media='all'/>
<link rel='stylesheet' id='social-logos-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all'/>
<link rel='stylesheet' id='open-sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.8.1' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.2.1' type='text/css' media='all'/>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cdp_cookies_info = {"url_plugin":"http:\/\/www.javiergutierrezchamorro.com\/wp-content\/plugins\/asesor-cookies-para-la-ley-en-espana\/plugin.php","url_admin_ajax":"http:\/\/www.javiergutierrezchamorro.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/asesor-cookies-para-la-ley-en-espana/html/front/principal.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='http://www.javiergutierrezchamorro.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.javiergutierrezchamorro.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.javiergutierrezchamorro.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.8.1"/>
<link rel='shortlink' href='http://www.javiergutierrezchamorro.com/?p=3138'/>
<link rel="alternate" type="application/json+oembed" href="http://www.javiergutierrezchamorro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.javiergutierrezchamorro.com%2Fuptime-2-dos%2F3138"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.javiergutierrezchamorro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.javiergutierrezchamorro.com%2Fuptime-2-dos%2F3138&#038;format=xml"/>
<style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important;}</style>
</head>
<body class="inner">
 
<div id="page" class="with-sidebar">
 
<div id="header-wrap">
<div id="header" class="block-content">
<div id="pagetitle" class="clearfix">
<h1 class="logo"><a href="http://www.javiergutierrezchamorro.com">Bitácora de Javier Gutiérrez Chamorro (Guti)</a></h1>
<h4>Mi nombre es Javier Gutiérrez Chamorro (Guti). Tengo 41 años, y también se me conoce por Guti o Nikkho.</h4>
</div>
</div>
</div>
 
 
<div id="main-wrap1">
<div id="main-wrap2">
 
<div id="main" class="block-content clearfix">
<div class="mask-main rightdiv">
<div class="mask-left">
 
<div class="col1">
<div id="main-content">
<div class="navigation clearfix">
<div class="alignleft">&laquo; <a href="http://www.javiergutierrezchamorro.com/protocolo-dcf/3146" rel="prev">Protocolo DCF</a></div>
<div class="alignright"></div>
</div>
 
<div id="post-3138" class="post-3138 post type-post status-publish format-standard hentry category-informatica category-programacion category-retro category-software">
<h2 class="post-title">Uptime 2 para DOS</h2> <div id="post-ratings-3138" class="post-ratings" itemscope itemtype="http://schema.org/Article" data-nonce="9782fdb881"><img id="rating_3138_1" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_off.gif" alt="1 Estrella" title="1 Estrella" onmouseover="current_rating(3138, 1, '1 Estrella');" onmouseout="ratings_off(0, 0, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/><img id="rating_3138_2" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_off.gif" alt="2 Estrellas" title="2 Estrellas" onmouseover="current_rating(3138, 2, '2 Estrellas');" onmouseout="ratings_off(0, 0, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/><img id="rating_3138_3" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_off.gif" alt="3 Estrellas" title="3 Estrellas" onmouseover="current_rating(3138, 3, '3 Estrellas');" onmouseout="ratings_off(0, 0, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/><img id="rating_3138_4" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_off.gif" alt="4 Estrellas" title="4 Estrellas" onmouseover="current_rating(3138, 4, '4 Estrellas');" onmouseout="ratings_off(0, 0, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/><img id="rating_3138_5" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_off.gif" alt="5 Estrellas" title="5 Estrellas" onmouseover="current_rating(3138, 5, '5 Estrellas');" onmouseout="ratings_off(0, 0, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/> (No Ratings Yet)<br/><span class="post-ratings-text" id="ratings_3138_text"></span><meta itemprop="headline" content="Uptime 2 para DOS"/><meta itemprop="description" content="No hace mucho que os hablaba de Uptime para DOS, y que publiqu&eacute; la versi&oacute;n 1.00 y la 1.10, un sencillo programa escrito en FAST, y que replicaba el comando uptime de UNIX.

El desarrollo empez&oacute; muy ..."/><meta itemprop="datePublished" content="2017-08-04T11:31:21+00:00"/><meta itemprop="dateModified" content="2017-06-08T10:54:38+00:00"/><meta itemprop="url" content="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138"/><meta itemprop="author" content="Javier Gutiérrez Chamorro (Guti)"/><meta itemprop="mainEntityOfPage" content="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138"/><div style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Bitácora de Javier Gutiérrez Chamorro (Guti)"/><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""/></div></div></div> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-3625063062589476" data-ad-slot="7483177342"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script><br/><br/> <div class="post-content clearfix">
<p>No hace mucho que os hablaba de <a href="http://www.javiergutierrezchamorro.com/uptime-para-dos/3137" target="_blank">Uptime para DOS</a>, y que publiqué la versión 1.00 y la 1.10, un sencillo programa escrito en <a href="http://www.javiergutierrezchamorro.com/fast-compiler/3129" target="_blank">FAST</a>, y que replicaba el comando uptime de UNIX.</p>
<p>El desarrollo empezó muy bien, con una eficiencia casi de ensamblador, pero contando con la ventaja de las estructuras de alto nivel. Hasta que me topé con el impedimento de las conversiones entre números de 16 y 32 bit, y con el maldito bug de mod32.</p>
<p>Entonces me planteé escribir la versión 2.00 en ensamblador. Menos de 150 lineas en código <b>FAST</b>, no parecían gran cosa en ensamblador. Así que comencé con <a href="http://www.javiergutierrezchamorro.com/beepbell-en-ensamblador/3127" target="_blank">JWASM (Japheth&#8217;s Watcom Assembler)</a>, un ensamblador y enlazador al mismo tiempo, compatible con MASM, de código abierto y que se contruyó sobre la base de <b>Open Watcom Assembler (WASM / OWASM)</b>.</p>
<p>Durante el desarrollo descubrí <a href="http://www.terraspace.co.uk/uasm.html" target="_blank">UASM</a> antes <b>HASM</b> y antes <b>HJWASM</b>, un fork de <b>JWASM</b> que había quedado abandonado, y que me inspiró nuevas motiviaciones a la hora de programar. También tuve ocasión de probar <b>ASMC</b>, otro fork paralelo también de JWASM.</p>
<p>Al final, esas menos de 150 lineas, se convirtieron en casi 500 lineas de ensamblador en Uptime 2.10, incluyendo funciones genéricas como la impresión de caracteres, de cadenas, o la <a href="http://www.javiergutierrezchamorro.com/fps-en-ensamblador/2017" target="_blank">conversión</a> de BCD a decimal. Finalmente, esas 500 lineas de assembly, resultaron ser el programa más largo que había hecho a tan bajo nivel, desde hace casi 20 años, y aunque tuve que reaprender, fue curioso ver como hay cosas que nunca se olvidan.</p>
<p><img src="http://www.javiergutierrezchamorro.com/wp-content/uploads/2017/08/uptime_2.png"/></p>
<p>A pesar de ello, el ejecutable resultante, se redujo de 2.005 bytes en FAST a 1.310 bytes con ensamblador, todo ello a pesar de las nuevas características que aproveché para añadir:<br/>
&#8211; Nueva opción -r para forzar la inicialización.<br/>
&#8211; Ayuda más completa.<br/>
&#8211; Comprobación de CMOS mejorada.</p>
<p>Finalmente, quedó un pequeño programita, con unos requisitos mínimos, que hoy en día os parecerían increíbles, y que lo harían funcionar en un PC de 1983 sin problemas:<br/>
&#8211; Sistema operativo compatible MS-DOS 2.0 o superior.<br/>
&#8211; CPU 8088 o superior.<br/>
&#8211; 3 Kb. de espacio libre en disco/disquette.<br/>
&#8211; 4 Kb. de memoria convencional disponible.</p>
<p>Como de costumbre, tenéis tanto en la <a href="http://nikkhokkho.sourceforge.net/static.php?page=UPTIME" target="_blank">página oficial</a> como en <a href="https://sourceforge.net/projects/nikkhokkho/files/UPTIME/" target="_blank">Sourceforge</a> el código fuente completo y los ejecutables, pero por lo que pudiera pasar, lo copio también <a href="http://javiergutierrezchamorro.com/wp-content/uploads/2017/08/uptime_2.zip" target="_blank">aquí (3 Kb. en formato ZIP)</a>. Para aquellos que tengáis curiosidad de la pinta que tiene el código FAST, lo pongo completo a continuación:</p>
<div class="wp_syntax" style="position:relative;"><table><tr><td class="code"><pre class="asm" style="font-family:monospace;"><span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #339933;">.</span>model tiny
<span style="color: #339933;">.</span><span style="color: #0000ff; font-weight: bold;">stack</span> <span style="color: #ff0000;">64</span>
<span style="color: #339933;">.</span><span style="color: #0000ff; font-weight: bold;">code</span>
org <span style="color: #ff0000;">100h</span>
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #339933;">.</span>startup
&nbsp;
<span style="color: #666666; font-style: italic;">;Parse command-line options</span>
<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #46aa03; font-weight: bold;">ds</span><span style="color: #339933;">:</span><span style="color: #009900; font-weight: bold;">&#91;</span><span style="color: #ff0000;">82h</span><span style="color: #009900; font-weight: bold;">&#93;</span>
<span style="color: #339933;">.</span>switch <span style="color: #46aa03; font-weight: bold;">ax</span>
	<span style="color: #339933;">.</span>case <span style="color: #7f007f;">'h-'</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'H-'</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'?-'</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'h/'</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'H/'</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'?/'</span>
		<span style="color: #00007f; font-weight: bold;">call</span> ShowHelp
	<span style="color: #339933;">.</span>endc
	<span style="color: #339933;">.</span>case <span style="color: #7f007f;">'r-'</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'R-'</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'r/'</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'R/'</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> offset acReset
		<span style="color: #00007f; font-weight: bold;">call</span> PrintText
		<span style="color: #00007f; font-weight: bold;">call</span> DoReset
	<span style="color: #339933;">.</span>endc
	<span style="color: #339933;">.</span><span style="color: #0000ff; font-weight: bold;">default</span>
		<span style="color: #00007f; font-weight: bold;">call</span> DoIt
<span style="color: #339933;">.</span>endsw
<span style="color: #339933;">.</span>exit
&nbsp;
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
DoIt proc 
	<span style="color: #666666; font-style: italic;">;Print current time</span>
	<span style="color: #00007f; font-weight: bold;">call</span> GetCurrentTime
	<span style="color: #00007f; font-weight: bold;">call</span> GetAlarmTime
&nbsp;
	<span style="color: #666666; font-style: italic;">;If last time is zero, force automatic reset</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #009900; font-weight: bold;">&#93;</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #339933;">+</span><span style="color: #ff0000;">2</span><span style="color: #009900; font-weight: bold;">&#93;</span>
	<span style="color: #339933;">.</span>if <span style="color: #009900; font-weight: bold;">&#40;</span><span style="color: #46aa03; font-weight: bold;">dx</span> == <span style="color: #ff0000;">0</span><span style="color: #009900; font-weight: bold;">&#41;</span>
		<span style="color: #339933;">.</span>if <span style="color: #009900; font-weight: bold;">&#40;</span><span style="color: #46aa03; font-weight: bold;">ax</span> == <span style="color: #ff0000;">0</span><span style="color: #009900; font-weight: bold;">&#41;</span>
			<span style="color: #00007f; font-weight: bold;">call</span> DoReset
		<span style="color: #339933;">.</span>endif
	<span style="color: #339933;">.</span>endif
&nbsp;
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">movzx</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> iHour
	else
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> iHour
	endif
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">si</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">2</span>
	<span style="color: #00007f; font-weight: bold;">call</span> PrintNumber0
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">':'</span>
	<span style="color: #00007f; font-weight: bold;">call</span> PrintChar
&nbsp;
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">movzx</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> iMinute
	else
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> iMinute
	endif
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">si</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">2</span>
	<span style="color: #00007f; font-weight: bold;">call</span> PrintNumber0
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">':'</span>
	<span style="color: #00007f; font-weight: bold;">call</span> PrintChar
&nbsp;
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">movzx</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> iSecond
	else
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> iSecond
	endif
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">si</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">2</span>
	<span style="color: #00007f; font-weight: bold;">call</span> PrintNumber0
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> offset acStart
	<span style="color: #00007f; font-weight: bold;">call</span> PrintText
&nbsp;
	<span style="color: #666666; font-style: italic;">;Substract seconds from startup seconds</span>
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">eax</span><span style="color: #339933;">,</span> <span style="color: #0000ff; font-weight: bold;">dword</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSeconds<span style="color: #009900; font-weight: bold;">&#93;</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ebx</span><span style="color: #339933;">,</span> <span style="color: #0000ff; font-weight: bold;">dword</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #009900; font-weight: bold;">&#93;</span>
		<span style="color: #00007f; font-weight: bold;">sub</span> <span style="color: #46aa03; font-weight: bold;">eax</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ebx</span>
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">edx</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">edx</span>		
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ebx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">3600</span>
		<span style="color: #00007f; font-weight: bold;">div</span> <span style="color: #46aa03; font-weight: bold;">ebx</span>
	else
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSeconds<span style="color: #009900; font-weight: bold;">&#93;</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSeconds<span style="color: #339933;">+</span><span style="color: #ff0000;">2</span><span style="color: #009900; font-weight: bold;">&#93;</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bx</span><span style="color: #339933;">,</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #009900; font-weight: bold;">&#93;</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">cx</span><span style="color: #339933;">,</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #339933;">+</span><span style="color: #ff0000;">2</span><span style="color: #009900; font-weight: bold;">&#93;</span>
		<span style="color: #00007f; font-weight: bold;">sub</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">bx</span>
		<span style="color: #00007f; font-weight: bold;">sbb</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">cx</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">3600</span>
		<span style="color: #00007f; font-weight: bold;">div</span> <span style="color: #46aa03; font-weight: bold;">bx</span>
	endif
	<span style="color: #666666; font-style: italic;">;mov word ptr [lSecondsE], ax</span>
	<span style="color: #666666; font-style: italic;">;mov word ptr [lSecondsE+2], dx</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;mov ax, word ptr [lSecondsE]</span>
	<span style="color: #666666; font-style: italic;">;mov dx, word ptr [lSecondsE+2]</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;Print hours elapsed</span>
	<span style="color: #00007f; font-weight: bold;">call</span> PrintNumber
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> offset acHour
	<span style="color: #00007f; font-weight: bold;">call</span> PrintText
&nbsp;
	<span style="color: #666666; font-style: italic;">;Print minutes elapsed</span>
	<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">60</span>
	<span style="color: #00007f; font-weight: bold;">div</span> <span style="color: #46aa03; font-weight: bold;">bx</span>
	<span style="color: #00007f; font-weight: bold;">call</span> PrintNumber
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> offset acMinute
	<span style="color: #00007f; font-weight: bold;">call</span> PrintText
&nbsp;
	<span style="color: #666666; font-style: italic;">;Print seconds elapsed</span>
	<span style="color: #00007f; font-weight: bold;">call</span> PrintNumber
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> offset acSecond
	<span style="color: #00007f; font-weight: bold;">call</span> PrintText
&nbsp;
	<span style="color: #666666; font-style: italic;">;Return</span>
	<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">ret</span>
DoIt endp
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
DoReset proc uses <span style="color: #46aa03; font-weight: bold;">ax</span>
	<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #00007f; font-weight: bold;">xchg</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">1</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">xchg</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">71h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;Check CMOS is present</span>
	<span style="color: #00007f; font-weight: bold;">xchg</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">1</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #339933;">.</span>if <span style="color: #009900; font-weight: bold;">&#40;</span><span style="color: #46aa03; font-weight: bold;">al</span> != <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #009900; font-weight: bold;">&#41;</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> offset acNoCMOS
		<span style="color: #00007f; font-weight: bold;">call</span> PrintText
		<span style="color: #339933;">.</span>exit
	<span style="color: #339933;">.</span>endif
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">2</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #00007f; font-weight: bold;">xchg</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">3</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">xchg</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">71h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">4</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #00007f; font-weight: bold;">xchg</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">5</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">xchg</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">71h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">call</span> GetAlarmTime
	<span style="color: #00007f; font-weight: bold;">ret</span>
DoReset endp
&nbsp;
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
ShowHelp proc
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> offset acCopyright
	<span style="color: #00007f; font-weight: bold;">call</span> PrintText
&nbsp;
	<span style="color: #00007f; font-weight: bold;">call</span> ReadChar
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> offset acCrLf
	<span style="color: #00007f; font-weight: bold;">call</span> PrintText
&nbsp;
	<span style="color: #666666; font-style: italic;">;Return</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #339933;">-</span><span style="color: #ff0000;">1</span>
	<span style="color: #00007f; font-weight: bold;">ret</span>
ShowHelp endp
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #666666; font-style: italic;">;386</span>
if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
	GetCurrentTime proc uses <span style="color: #46aa03; font-weight: bold;">eax</span> <span style="color: #46aa03; font-weight: bold;">bx</span>
else
	GetCurrentTime proc uses <span style="color: #46aa03; font-weight: bold;">ax</span> <span style="color: #46aa03; font-weight: bold;">bx</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
endif
	<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #00007f; font-weight: bold;">call</span> BCD2Bin
	<span style="color: #00007f; font-weight: bold;">mov</span> iSecond<span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">2</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #00007f; font-weight: bold;">call</span> BCD2Bin
	<span style="color: #00007f; font-weight: bold;">mov</span> iMinute<span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">4</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #00007f; font-weight: bold;">call</span> BCD2Bin
	<span style="color: #339933;">.</span>if <span style="color: #009900; font-weight: bold;">&#40;</span><span style="color: #46aa03; font-weight: bold;">al</span> &gt; <span style="color: #ff0000;">81h</span><span style="color: #009900; font-weight: bold;">&#41;</span>
		<span style="color: #00007f; font-weight: bold;">sub</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">75h</span>
	<span style="color: #339933;">.</span>endif	
	<span style="color: #00007f; font-weight: bold;">mov</span> iHour<span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;Fill lSeconds with total number of seconds</span>
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">movzx</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> iSecond
	else
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> iSecond
	endif
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSeconds<span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ax</span>	
&nbsp;
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">movzx</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> iMinute
	else
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> iMinute
	endif
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">60</span>
	<span style="color: #00007f; font-weight: bold;">mul</span> <span style="color: #46aa03; font-weight: bold;">bx</span>
	<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSeconds<span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ax</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">movzx</span> <span style="color: #46aa03; font-weight: bold;">eax</span><span style="color: #339933;">,</span> iHour
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ebx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">3600</span>
		<span style="color: #00007f; font-weight: bold;">mul</span> <span style="color: #46aa03; font-weight: bold;">ebx</span>
		<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #0000ff; font-weight: bold;">dword</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSeconds<span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">eax</span>	
	else
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> iHour
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">3600</span>
		<span style="color: #00007f; font-weight: bold;">mul</span> <span style="color: #46aa03; font-weight: bold;">bx</span>
		<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSeconds<span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ax</span>
		<span style="color: #00007f; font-weight: bold;">adc</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSeconds<span style="color: #339933;">+</span><span style="color: #ff0000;">2</span><span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
	endif
&nbsp;
	<span style="color: #00007f; font-weight: bold;">ret</span>
GetCurrentTime endp
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
	GetAlarmTime proc uses <span style="color: #46aa03; font-weight: bold;">eax</span> <span style="color: #46aa03; font-weight: bold;">bx</span>
else
	GetAlarmTime proc uses <span style="color: #46aa03; font-weight: bold;">ax</span> <span style="color: #46aa03; font-weight: bold;">bx</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
endif
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">1</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #00007f; font-weight: bold;">call</span> BCD2Bin
	<span style="color: #00007f; font-weight: bold;">mov</span> iSecondA<span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">3</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #00007f; font-weight: bold;">call</span> BCD2Bin
	<span style="color: #00007f; font-weight: bold;">mov</span> iMinuteA<span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">5</span>
	<span style="color: #00007f; font-weight: bold;">out</span> <span style="color: #ff0000;">70h</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">in</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">71h</span>
	<span style="color: #00007f; font-weight: bold;">call</span> BCD2Bin
	<span style="color: #339933;">.</span>if <span style="color: #009900; font-weight: bold;">&#40;</span><span style="color: #46aa03; font-weight: bold;">al</span> &gt; <span style="color: #ff0000;">81h</span><span style="color: #009900; font-weight: bold;">&#41;</span>
		<span style="color: #00007f; font-weight: bold;">sub</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">75h</span>
	<span style="color: #339933;">.</span>endif	
	<span style="color: #00007f; font-weight: bold;">mov</span> iHourA<span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;Fill lSeconds with total number of seconds</span>
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">movzx</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> iSecondA
	else
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> iSecondA
	endif
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ax</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">movzx</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> iMinuteA
	else
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> iMinuteA
	endif
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">60</span>
	<span style="color: #00007f; font-weight: bold;">mul</span> <span style="color: #46aa03; font-weight: bold;">bx</span>
	<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ax</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;386</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">1000b</span>
		<span style="color: #00007f; font-weight: bold;">movzx</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> iHourA
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ebx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">3600</span>
		<span style="color: #00007f; font-weight: bold;">mul</span> <span style="color: #46aa03; font-weight: bold;">ebx</span>
		<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #0000ff; font-weight: bold;">dword</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">eax</span>
	else
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> iHourA
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">3600</span>
		<span style="color: #00007f; font-weight: bold;">mul</span> <span style="color: #46aa03; font-weight: bold;">bx</span>
		<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ax</span>
		<span style="color: #00007f; font-weight: bold;">adc</span> <span style="color: #0000ff; font-weight: bold;">word</span> ptr <span style="color: #009900; font-weight: bold;">&#91;</span>lSecondsA<span style="color: #339933;">+</span><span style="color: #ff0000;">2</span><span style="color: #009900; font-weight: bold;">&#93;</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
	endif
&nbsp;
	<span style="color: #00007f; font-weight: bold;">ret</span>
GetAlarmTime endp
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #666666; font-style: italic;">;Number in AL</span>
<span style="color: #adadad; font-style: italic;">BCD2</span>Bin proc uses <span style="color: #46aa03; font-weight: bold;">bx</span>
	<span style="color: #666666; font-style: italic;">;  ( (bcd &amp; 0xF0) &gt;&gt; 1) + ( (bcd &amp; 0xF0) &gt;&gt; 3) + (bcd &amp; 0xf)].</span>
	<span style="color: #666666; font-style: italic;">; (bcd / 16) * 10) + (bcd &amp; 0xf)</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">0f0h</span>
	<span style="color: #00007f; font-weight: bold;">shr</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">1</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bl</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
	<span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">0f0h</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;186</span>
	if @<span style="color: #0000ff; font-weight: bold;">cpu</span> <span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #ff0000;">10b</span>
		<span style="color: #00007f; font-weight: bold;">shr</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">3</span>
	else
		rept <span style="color: #ff0000;">3</span>
			<span style="color: #00007f; font-weight: bold;">shr</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">1</span>
		endm
	endif
&nbsp;
	<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #46aa03; font-weight: bold;">bl</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ah</span>
	<span style="color: #00007f; font-weight: bold;">and</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">0fh</span>
	<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #46aa03; font-weight: bold;">bl</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
&nbsp;
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">al</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">bl</span>	
&nbsp;
	<span style="color: #00007f; font-weight: bold;">ret</span>
<span style="color: #adadad; font-style: italic;">BCD2</span>Bin endp
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #666666; font-style: italic;">;Text in DX</span>
PrintText proc uses <span style="color: #46aa03; font-weight: bold;">ax</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">9</span>
	<span style="color: #00007f; font-weight: bold;">int</span> <span style="color: #ff0000;">21h</span>
	<span style="color: #00007f; font-weight: bold;">ret</span>
PrintText endp
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #666666; font-style: italic;">;Returns char in AL</span>
ReadChar proc
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">8</span>
	<span style="color: #00007f; font-weight: bold;">int</span> <span style="color: #ff0000;">21h</span>
	<span style="color: #00007f; font-weight: bold;">ret</span>
ReadChar endp
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #666666; font-style: italic;">;Char in AL</span>
PrintChar proc uses <span style="color: #46aa03; font-weight: bold;">dx</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">2</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dl</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">al</span>
	<span style="color: #00007f; font-weight: bold;">int</span> <span style="color: #ff0000;">21h</span>
	<span style="color: #00007f; font-weight: bold;">ret</span>
PrintChar endp
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #666666; font-style: italic;">;Number in AX</span>
PrintNumber proc uses <span style="color: #46aa03; font-weight: bold;">ax</span> <span style="color: #46aa03; font-weight: bold;">bx</span> <span style="color: #46aa03; font-weight: bold;">cx</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
	<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">cx</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">cx</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
&nbsp;
	<span style="color: #339933;">.</span>repeat
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
		<span style="color: #00007f; font-weight: bold;">div</span> <span style="color: #46aa03; font-weight: bold;">bx</span>	<span style="color: #666666; font-style: italic;">;divide by ten</span>
&nbsp;
		<span style="color: #00007f; font-weight: bold;">push</span> <span style="color: #46aa03; font-weight: bold;">ax</span>
		<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #46aa03; font-weight: bold;">dl</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'0'</span>		<span style="color: #666666; font-style: italic;">;convert dl to ascii</span>
		<span style="color: #00007f; font-weight: bold;">pop</span> <span style="color: #46aa03; font-weight: bold;">ax</span>			<span style="color: #666666; font-style: italic;">;restore ax</span>
&nbsp;
		<span style="color: #00007f; font-weight: bold;">push</span> <span style="color: #46aa03; font-weight: bold;">dx</span>			<span style="color: #666666; font-style: italic;">;digits are in reversed order, must use stack</span>
		<span style="color: #00007f; font-weight: bold;">inc</span> <span style="color: #46aa03; font-weight: bold;">cx</span>			<span style="color: #666666; font-style: italic;">;remember how many digits we pushed to stack</span>
		<span style="color: #00007f; font-weight: bold;">test</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ax</span>		<span style="color: #666666; font-style: italic;">;if ax is zero, we can quit</span>
	<span style="color: #339933;">.</span>until zero?		<span style="color: #666666; font-style: italic;">;jnz</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;cx is already set</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">2</span>			<span style="color: #666666; font-style: italic;">;2 is the function number of output char in the DOS Services.</span>
	PrintNumberLoop<span style="color: #339933;">:</span>
		<span style="color: #00007f; font-weight: bold;">pop</span> <span style="color: #46aa03; font-weight: bold;">dx</span>			<span style="color: #666666; font-style: italic;">;restore digits from last to first</span>
		<span style="color: #00007f; font-weight: bold;">int</span> <span style="color: #ff0000;">21h</span>		<span style="color: #666666; font-style: italic;">;calls DOS Services</span>
	<span style="color: #00007f; font-weight: bold;">loop</span> PrintNumberLoop
&nbsp;
	<span style="color: #00007f; font-weight: bold;">ret</span>
PrintNumber endp
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #666666; font-style: italic;">;Number in AX, Digits in SI</span>
PrintNumber0 proc uses <span style="color: #46aa03; font-weight: bold;">ax</span> <span style="color: #46aa03; font-weight: bold;">bx</span> <span style="color: #46aa03; font-weight: bold;">cx</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
	<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">cx</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">cx</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">bx</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
&nbsp;
	<span style="color: #339933;">.</span>repeat
		<span style="color: #00007f; font-weight: bold;">xor</span> <span style="color: #46aa03; font-weight: bold;">dx</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">dx</span>
		<span style="color: #00007f; font-weight: bold;">div</span> <span style="color: #46aa03; font-weight: bold;">bx</span>			<span style="color: #666666; font-style: italic;">;divide by ten</span>
&nbsp;
		<span style="color: #00007f; font-weight: bold;">push</span> <span style="color: #46aa03; font-weight: bold;">ax</span>
		<span style="color: #00007f; font-weight: bold;">add</span> <span style="color: #46aa03; font-weight: bold;">dl</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'0'</span>		<span style="color: #666666; font-style: italic;">;convert dl to ascii</span>
		<span style="color: #00007f; font-weight: bold;">pop</span> <span style="color: #46aa03; font-weight: bold;">ax</span>			<span style="color: #666666; font-style: italic;">;restore ax</span>
&nbsp;
		<span style="color: #00007f; font-weight: bold;">push</span> <span style="color: #46aa03; font-weight: bold;">dx</span>			<span style="color: #666666; font-style: italic;">;digits are in reversed order, must use stack</span>
		<span style="color: #00007f; font-weight: bold;">inc</span> <span style="color: #46aa03; font-weight: bold;">cx</span>			<span style="color: #666666; font-style: italic;">;remember how many digits we pushed to stack</span>
		<span style="color: #00007f; font-weight: bold;">test</span> <span style="color: #46aa03; font-weight: bold;">ax</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">ax</span>		<span style="color: #666666; font-style: italic;">;if ax is zero, we can quit</span>
	<span style="color: #339933;">.</span>until zero?		<span style="color: #666666; font-style: italic;">;jnz</span>
&nbsp;
	<span style="color: #666666; font-style: italic;">;cx is already set</span>
	<span style="color: #666666; font-style: italic;">;mov ah, 2			;2 is the function number of output char in the DOS Services.</span>
	<span style="color: #00007f; font-weight: bold;">push</span> <span style="color: #46aa03; font-weight: bold;">cx</span>
	<span style="color: #00007f; font-weight: bold;">sub</span> <span style="color: #46aa03; font-weight: bold;">si</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">cx</span>
	<span style="color: #339933;">.</span>if <span style="color: #009900; font-weight: bold;">&#40;</span><span style="color: #46aa03; font-weight: bold;">si</span> &gt; <span style="color: #ff0000;">0</span><span style="color: #009900; font-weight: bold;">&#41;</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">cx</span><span style="color: #339933;">,</span> <span style="color: #46aa03; font-weight: bold;">si</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">dl</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'0'</span>
		<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">2</span>
		PrintNumber0Loop0<span style="color: #339933;">:</span>
			<span style="color: #00007f; font-weight: bold;">int</span> <span style="color: #ff0000;">21h</span>			<span style="color: #666666; font-style: italic;">;fast DOS output</span>
		<span style="color: #00007f; font-weight: bold;">loop</span> PrintNumber0Loop0
	<span style="color: #339933;">.</span>endif
	<span style="color: #00007f; font-weight: bold;">pop</span> <span style="color: #46aa03; font-weight: bold;">cx</span>
	<span style="color: #00007f; font-weight: bold;">mov</span> <span style="color: #46aa03; font-weight: bold;">ah</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">2</span>
&nbsp;
	PrintNumber0Loop<span style="color: #339933;">:</span>
		<span style="color: #00007f; font-weight: bold;">pop</span> <span style="color: #46aa03; font-weight: bold;">dx</span>			<span style="color: #666666; font-style: italic;">;restore digits from last to first</span>
		<span style="color: #00007f; font-weight: bold;">int</span> <span style="color: #ff0000;">21h</span>		<span style="color: #666666; font-style: italic;">;calls DOS Services</span>
	<span style="color: #00007f; font-weight: bold;">loop</span> PrintNumber0Loop
&nbsp;
	<span style="color: #00007f; font-weight: bold;">ret</span>
PrintNumber0 endp
&nbsp;
&nbsp;
<span style="color: #666666; font-style: italic;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------</span>
<span style="color: #0000ff; font-weight: bold;">.data</span>
lSeconds		<span style="color: #0000ff; font-weight: bold;">dd</span> ?
lSecondsA		<span style="color: #0000ff; font-weight: bold;">dd</span> ?
<span style="color: #666666; font-style: italic;">;lSecondsE		dd ?</span>
<span style="color: #666666; font-style: italic;">;iYear			dw ?</span>
<span style="color: #666666; font-style: italic;">;iMonth			db ?</span>
<span style="color: #666666; font-style: italic;">;iDay			db ?</span>
iHour			<span style="color: #0000ff; font-weight: bold;">db</span> ?
iMinute			<span style="color: #0000ff; font-weight: bold;">db</span> ?
iSecond			<span style="color: #0000ff; font-weight: bold;">db</span> ?
iYearA			<span style="color: #0000ff; font-weight: bold;">dw</span> ?
iMonthA			<span style="color: #0000ff; font-weight: bold;">db</span> ?
iDayA			<span style="color: #0000ff; font-weight: bold;">db</span> ?
iHourA			<span style="color: #0000ff; font-weight: bold;">db</span> ?
iMinuteA		<span style="color: #0000ff; font-weight: bold;">db</span> ?
iSecondA		<span style="color: #0000ff; font-weight: bold;">db</span> ?
acStart			<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot; up &quot;</span> <span style="color: #339933;">,</span> <span style="color: #7f007f;">'$'</span>
acHour			<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot; hour, &quot;</span> <span style="color: #339933;">,</span> <span style="color: #7f007f;">'$'</span>
acMinute		<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot; minute, &quot;</span> <span style="color: #339933;">,</span> <span style="color: #7f007f;">'$'</span>
acSecond		<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot; second, &quot;</span>
acEnd			<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;1 user, load average: 0.00, 0.00, 0.00&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'$'</span>
acCrLf			<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'$'</span>
acReset			<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;Uptime counter reseted to zero.&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'$'</span>
acNoCMOS		<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;No CMOS available to write.&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #7f007f;">'$'</span>
acCopyright		<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;UPTIME R2.40                       (c) 2017 by Javier Gutierrez Chamorro (Guti)&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;Display system uptime under DOS&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
acHelp			<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;UPTIME displays DOS uptime, by automatically detecting when it was firstly&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;booted, mimicing its UNIX counterparts.&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;Syntax is: UPTIME [-h|-r]&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;Examples:&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;	UPTIME -h&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;	Shows this help screen.&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;	UPTIME -r&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;	Forces reseting the counter. Useful if it is not automatically detected&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;	properly during startup.&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;More information at:&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;	http://nikkhokkho.sourceforge.net/static.php?page=UPTIME&quot;</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">13</span><span style="color: #339933;">,</span> <span style="color: #ff0000;">10</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">&quot;Press ENTER to continue...&quot;</span>
				<span style="color: #0000ff; font-weight: bold;">db</span> <span style="color: #7f007f;">'$'</span>
end</pre></td></tr></table><p class="theCode" style="display:none;">;--------------------------------------------------------------------------------------------------------------------------------------------------------------
.model tiny
.stack 64
.code
org 100h
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
.startup
;Parse command-line options
mov ax, word ptr ds:[82h]
.switch ax
.case 'h-', 'H-', '?-', 'h/', 'H/', '?/'
call ShowHelp
.endc
.case 'r-', 'R-', 'r/', 'R/'
mov dx, offset acReset
call PrintText
call DoReset
.endc
.default
call DoIt
.endsw
.exit
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
DoIt proc
;Print current time
call GetCurrentTime
call GetAlarmTime
;If last time is zero, force automatic reset
mov ax, word ptr [lSecondsA]
mov dx, word ptr [lSecondsA+2]
.if (dx == 0)
.if (ax == 0)
call DoReset
.endif
.endif
;386
if @cpu and 1000b
movzx ax, iHour
else
xor ah, ah
mov al, iHour
endif
mov si, 2
call PrintNumber0
mov al, ':'
call PrintChar
;386
if @cpu and 1000b
movzx ax, iMinute
else
xor ah, ah
mov al, iMinute
endif
mov si, 2
call PrintNumber0
mov al, ':'
call PrintChar
;386
if @cpu and 1000b
movzx ax, iSecond
else
xor ah, ah
mov al, iSecond
endif
mov si, 2
call PrintNumber0
mov dx, offset acStart
call PrintText
;Substract seconds from startup seconds
;386
if @cpu and 1000b
mov eax, dword ptr [lSeconds]
mov ebx, dword ptr [lSecondsA]
sub eax, ebx
xor edx, edx
mov ebx, 3600
div ebx
else
mov ax, word ptr [lSeconds]
mov dx, word ptr [lSeconds+2]
mov bx, word ptr [lSecondsA]
mov cx, word ptr [lSecondsA+2]
sub ax, bx
sbb dx, cx
mov bx, 3600
div bx
endif
;mov word ptr [lSecondsE], ax
;mov word ptr [lSecondsE+2], dx
;mov ax, word ptr [lSecondsE]
;mov dx, word ptr [lSecondsE+2]
;Print hours elapsed
call PrintNumber
mov ax, dx
mov dx, offset acHour
call PrintText
;Print minutes elapsed
xor dx, dx
mov bx, 60
div bx
call PrintNumber
mov ax, dx
mov dx, offset acMinute
call PrintText
;Print seconds elapsed
call PrintNumber
mov dx, offset acSecond
call PrintText
;Return
xor al, al
ret
DoIt endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
DoReset proc uses ax
xor al, al
out 70h, al
in al, 71h
xchg ah, al
mov al, 1
out 70h, al
xchg ah, al
out 71h, al
;Check CMOS is present
xchg ah, al
mov al, 1
out 70h, al
in al, 71h
.if (al != ah)
mov dx, offset acNoCMOS
call PrintText
.exit
.endif
mov al, 2
out 70h, al
in al, 71h
xchg ah, al
mov al, 3
out 70h, al
xchg ah, al
out 71h, al
mov al, 4
out 70h, al
in al, 71h
xchg ah, al
mov al, 5
out 70h, al
xchg ah, al
out 71h, al
call GetAlarmTime
ret
DoReset endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
ShowHelp proc
mov dx, offset acCopyright
call PrintText
call ReadChar
mov dx, offset acCrLf
call PrintText
;Return
mov al, -1
ret
ShowHelp endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
;386
if @cpu and 1000b
GetCurrentTime proc uses eax bx
else
GetCurrentTime proc uses ax bx dx
endif
xor al, al
out 70h, al
in al, 71h
call BCD2Bin
mov iSecond, al
mov al, 2
out 70h, al
in al, 71h
call BCD2Bin
mov iMinute, al
mov al, 4
out 70h, al
in al, 71h
call BCD2Bin
.if (al &gt; 81h)
sub al, 75h
.endif
mov iHour, al
;Fill lSeconds with total number of seconds
;386
if @cpu and 1000b
movzx ax, iSecond
else
xor ah, ah
mov al, iSecond
endif
mov word ptr [lSeconds], ax
;386
if @cpu and 1000b
movzx ax, iMinute
else
xor ah, ah
mov al, iMinute
endif
mov bx, 60
mul bx
add word ptr [lSeconds], ax
;386
if @cpu and 1000b
movzx eax, iHour
mov ebx, 3600
mul ebx
add dword ptr [lSeconds], eax
else
xor ah, ah
mov al, iHour
mov bx, 3600
mul bx
add word ptr [lSeconds], ax
adc word ptr [lSeconds+2], dx
endif
ret
GetCurrentTime endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
if @cpu and 1000b
GetAlarmTime proc uses eax bx
else
GetAlarmTime proc uses ax bx dx
endif
mov al, 1
out 70h, al
in al, 71h
call BCD2Bin
mov iSecondA, al
mov al, 3
out 70h, al
in al, 71h
call BCD2Bin
mov iMinuteA, al
mov al, 5
out 70h, al
in al, 71h
call BCD2Bin
.if (al &gt; 81h)
sub al, 75h
.endif
mov iHourA, al
;Fill lSeconds with total number of seconds
;386
if @cpu and 1000b
movzx ax, iSecondA
else
xor ah, ah
mov al, iSecondA
endif
mov word ptr [lSecondsA], ax
;386
if @cpu and 1000b
movzx ax, iMinuteA
else
xor ah, ah
mov al, iMinuteA
endif
mov bx, 60
mul bx
add word ptr [lSecondsA], ax
;386
if @cpu and 1000b
movzx ax, iHourA
mov ebx, 3600
mul ebx
add dword ptr [lSecondsA], eax
else
xor ah, ah
mov al, iHourA
mov bx, 3600
mul bx
add word ptr [lSecondsA], ax
adc word ptr [lSecondsA+2], dx
endif
ret
GetAlarmTime endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
;Number in AL
BCD2Bin proc uses bx
; ( (bcd &amp; 0xF0) &gt;&gt; 1) + ( (bcd &amp; 0xF0) &gt;&gt; 3) + (bcd &amp; 0xf)].
; (bcd / 16) * 10) + (bcd &amp; 0xf)
mov ah, al
and al, 0f0h
shr al, 1
mov bl, al
mov al, ah
and al, 0f0h
;186
if @cpu and 10b
shr al, 3
else
rept 3
shr al, 1
endm
endif
add bl, al
mov al, ah
and al, 0fh
add bl, al
mov al, bl
ret
BCD2Bin endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
;Text in DX
PrintText proc uses ax
mov ah, 9
int 21h
ret
PrintText endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
;Returns char in AL
ReadChar proc
mov ah, 8
int 21h
ret
ReadChar endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
;Char in AL
PrintChar proc uses dx
mov ah, 2
mov dl, al
int 21h
ret
PrintChar endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
;Number in AX
PrintNumber proc uses ax bx cx dx
xor cx, cx
mov bx, 10
.repeat
xor dx, dx
div bx ;divide by ten
push ax
add dl, '0' ;convert dl to ascii
pop ax ;restore ax
push dx ;digits are in reversed order, must use stack
inc cx ;remember how many digits we pushed to stack
test ax, ax ;if ax is zero, we can quit
.until zero? ;jnz
;cx is already set
mov ah, 2 ;2 is the function number of output char in the DOS Services.
PrintNumberLoop:
pop dx ;restore digits from last to first
int 21h ;calls DOS Services
loop PrintNumberLoop
ret
PrintNumber endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
;Number in AX, Digits in SI
PrintNumber0 proc uses ax bx cx dx
xor cx, cx
mov bx, 10
.repeat
xor dx, dx
div bx ;divide by ten
push ax
add dl, '0' ;convert dl to ascii
pop ax ;restore ax
push dx ;digits are in reversed order, must use stack
inc cx ;remember how many digits we pushed to stack
test ax, ax ;if ax is zero, we can quit
.until zero? ;jnz
;cx is already set
;mov ah, 2 ;2 is the function number of output char in the DOS Services.
push cx
sub si, cx
.if (si &gt; 0)
mov cx, si
mov dl, '0'
mov ah, 2
PrintNumber0Loop0:
int 21h ;fast DOS output
loop PrintNumber0Loop0
.endif
pop cx
mov ah, 2
PrintNumber0Loop:
pop dx ;restore digits from last to first
int 21h ;calls DOS Services
loop PrintNumber0Loop
ret
PrintNumber0 endp
;--------------------------------------------------------------------------------------------------------------------------------------------------------------
.data
lSeconds dd ?
lSecondsA dd ?
;lSecondsE dd ?
;iYear dw ?
;iMonth db ?
;iDay db ?
iHour db ?
iMinute db ?
iSecond db ?
iYearA dw ?
iMonthA db ?
iDayA db ?
iHourA db ?
iMinuteA db ?
iSecondA db ?
acStart db &quot; up &quot; , '$'
acHour db &quot; hour, &quot; , '$'
acMinute db &quot; minute, &quot; , '$'
acSecond db &quot; second, &quot;
acEnd db &quot;1 user, load average: 0.00, 0.00, 0.00&quot;, 13, 10, '$'
acCrLf db 13, 10, '$'
acReset db &quot;Uptime counter reseted to zero.&quot;, 13, 10, '$'
acNoCMOS db &quot;No CMOS available to write.&quot;, 13, 10, '$'
acCopyright db 13, 10
db &quot;UPTIME R2.40 (c) 2017 by Javier Gutierrez Chamorro (Guti)&quot;, 13, 10
db &quot;Display system uptime under DOS&quot;, 13, 10, 10
acHelp db &quot;UPTIME displays DOS uptime, by automatically detecting when it was firstly&quot;, 13, 10
db &quot;booted, mimicing its UNIX counterparts.&quot;, 13, 10, 10
db &quot;Syntax is: UPTIME [-h|-r]&quot;, 13, 10, 10
db &quot;Examples:&quot;, 13, 10, 10
db &quot; UPTIME -h&quot;, 13, 10
db &quot; Shows this help screen.&quot;, 13, 10, 10
db &quot; UPTIME -r&quot;, 13, 10
db &quot; Forces reseting the counter. Useful if it is not automatically detected&quot;, 13, 10
db &quot; properly during startup.&quot;, 13, 10, 10
db &quot;More information at:&quot;, 13, 10
db &quot; http://nikkhokkho.sourceforge.net/static.php?page=UPTIME&quot;, 13, 10
db &quot;Press ENTER to continue...&quot;
db '$'
end</p></div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Compartir</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-3138" class="share-facebook sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=facebook" target="_blank" title="Haz clic para compartir en Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-3138" class="share-twitter sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=twitter" target="_blank" title="Haz clic para compartir en Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-3138" class="share-linkedin sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=linkedin" target="_blank" title="Haz clic para compartir en LinkedIn"><span>LinkedIn</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>Más</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-3138" class="share-google-plus-1 sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=google-plus-1" target="_blank" title="Haz clic para compartir en Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=reddit" target="_blank" title="Haz clic para compartir en Reddit"><span>Reddit</span></a></li><li class="share-end"></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=tumblr" target="_blank" title="Haz clic para compartir en Tumblr"><span>Tumblr</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-3138" class="share-pinterest sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=pinterest" target="_blank" title="Haz clic para compartir en Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=email" target="_blank" title="Haz clic para enviar por correo electrónico a un amigo"><span>Correo electrónico</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138#print" target="_blank" title="Haz clic para imprimir"><span>Imprimir</span></a></li><li class="share-end"></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=pocket" target="_blank" title="Haz clic para compartir en Pocket"><span>Pocket</span></a></li><li class="share-skype"><a rel="nofollow" data-shared="sharing-skype-3138" class="share-skype sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=skype" target="_blank" title="Compartir en Skype"><span>Skype</span></a></li><li class="share-end"></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="whatsapp://send?text=Uptime%202%20para%20DOS http%3A%2F%2Fwww.javiergutierrezchamorro.com%2Fuptime-2-dos%2F3138" target="_blank" title="Haz clic para compartir en WhatsApp"><span>WhatsApp</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon" href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138?share=telegram" target="_blank" title="Haz clic para compartir en Telegram"><span>Telegram</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Relacionado</em></h3>
</div> </div>
<p class="post-metadata">
Esta entrada se publicó el 4 de Agosto de 2017, 11:31 y está guardada en <a href="http://www.javiergutierrezchamorro.com/category/informatica" rel="category tag">Informática</a>, <a href="http://www.javiergutierrezchamorro.com/category/informatica/programacion" rel="category tag">Programación</a>, <a href="http://www.javiergutierrezchamorro.com/category/informatica/retro" rel="category tag">Retro</a>, <a href="http://www.javiergutierrezchamorro.com/category/informatica/software" rel="category tag">Software</a>. Puedes seguir las respuestas a esta entrada en <a href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138/feed" title="RSS 2.0">RSS 2.0</a>.
Puede ir hasta abajo y dejar una respuesta. No se permiten pings. </p>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-3625063062589476" data-ad-slot="7483177342"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script><br/><br/> </div>
 
<h3 class="comments">
2 Comments </h3>
 
<ul id="comments" class="clearfix">
 
<li class="comment even thread-even depth-1 with-avatar" id="comment-69374">
<div class="comment-mask regularcomment">
<div class="comment-main">
<div class="comment-wrap1">
<div class="comment-wrap2">
<div class="comment-head tiptrigger">
<p>
<a class="comment-id" href="#comment-69374">#1</a> by <b id="commentauthor-69374">bianamaran</b> on 4 de Agosto de 2017 - 13:04 </p>
<p class="controls tip">
<a class="quote" title="Citar" href="javascript:void(0);"><span>Citar</span></a> </p>
</div>
<div class="comment-body clearfix" id="comment-body-69374">
<div class="avatar"><img alt='' src="https://1.gravatar.com/avatar/797c6099e40dcbd3d78d0889533a8bf7?s=64&#038;d=mm&#038;r=x" srcset='http://1.gravatar.com/avatar/797c6099e40dcbd3d78d0889533a8bf7?s=128&amp;d=mm&amp;r=x 2x' class='avatar avatar-64 photo' height='64' width='64'/></div>
<div class="comment-text"><p>mod call call mod mod call call mod&#8230; Me mareo. Currazo que te has pegado Guti, me quito el sombrero.</p>
</div>
<a id="comment-reply-69374"></a>
</div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-3625063062589476" data-ad-slot="7483177342"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script><br/><br/>
</div>
</div>
</div>
</div>
</li> 
 
<li class="comment byuser comment-author-guti bypostauthor odd alt thread-odd thread-alt depth-1 with-avatar" id="comment-69376">
<div class="comment-mask admincomment">
<div class="comment-main">
<div class="comment-wrap1">
<div class="comment-wrap2">
<div class="comment-head tiptrigger">
<p>
<a class="comment-id" href="#comment-69376">#2</a> by <span class="with-tooltip"><a class="comment-author" id="commentauthor-69376" href="http://www.javiergutierrezchamorro.com">Javier Gutiérrez Chamorro (Guti)</a></span> on 4 de Agosto de 2017 - 14:39 </p>
<p class="controls tip">
<a class="quote" title="Citar" href="javascript:void(0);"><span>Citar</span></a> </p>
</div>
<div class="comment-body clearfix" id="comment-body-69376">
<div class="avatar"><img alt='' src="https://0.gravatar.com/avatar/fef7e7ec3b5cabd126f26228e7ae8022?s=64&#038;d=mm&#038;r=x" srcset='http://0.gravatar.com/avatar/fef7e7ec3b5cabd126f26228e7ae8022?s=128&amp;d=mm&amp;r=x 2x' class='avatar avatar-64 photo' height='64' width='64'/></div>
<div class="comment-text"><p>Gracias <b>bianamaran</b>. Es un trabajo más sencillo de lo que parece una vez tienes cierta soltura. Eso sí, utilidad práctica muy poca, pero reconozco que he disfrutado mucho programándolo y puliéndolo.</p>
<p>Date cuenta, que se utilizan ciertas construcciones de alto nivel: .if, .while, .case&#8230; ¡Imagina la pinta que habría tenido sin ellas!</p>
</div>
<a id="comment-reply-69376"></a>
</div>
<div id="adsadpv49480"></div><script type="text/javascript">var adpv_client="49480"; var adpv_width=728; var adpv_height=90; var adpv_container_id="adsadpv49480";</script><script type="text/javascript" src="http://ads.adpv.com/ads.js"></script><br/><br/>
</div>
</div>
</div>
</div>
</li> 
</ul>
<div id="respond">
<script type="text/javascript">
       function validatecomment(form){
         if(form.author.value == ('' || 'Your name (required)')){
           alert('Please enter your name');
           return false;
         }
         if(form.email.value == ('' || 'Your e-mail (required, will not be published)')){
           alert('Please enter your email address');
           return false;
         }
         if(form.comment.value == ('' || 'Type your comment here')){
           alert('Please type a comment');
           return false;
         }
         if(form.url.value == ('' || 'Your website')){
           form.url.value = '';
           return true;
         }
       }
      </script>
<div id="adsadpv49481"></div><script type="text/javascript">var adpv_client="49481"; var adpv_width=300; var adpv_height=250; var adpv_container_id="adsadpv49481";</script><script type="text/javascript" src="http://ads.adpv.com/ads.js"></script> <form action="http://www.javiergutierrezchamorro.com/wp-comments-post.php" method="post" id="commentform" onsubmit="return validatecomment(this);">
<div class="cancel-comment-reply"><a rel="nofollow" id="cancel-comment-reply-link" href="/uptime-2-dos/3138#respond" style="display:none;">Cancelar Respuesta</a></div> <div id="author_info">
<div class="row">
<input type="text" name="author" id="author" required class="textfield required" size="34" tabindex="1" value="" placeholder="Your name (required)"/>
</div>
<div class="row">
<input type="email" name="email" id="email" required class="textfield required" value="" placeholder="Your e-mail (required, will not be published)" size="60" tabindex="2"/>
</div>
<div class="row">
<input type="url" name="url" id="url" class="textfield" value="" placeholder="Your website" size="60" tabindex="3"/>
</div>
</div>
 
<div class="row">
<textarea name="comment" id="comment" required class="required" tabindex="4" rows="8" cols="60" placeholder="Type your comment here"></textarea>
<input type='hidden' name='comment_post_ID' value='3138' id='comment_post_ID'/>
<input type='hidden' name='comment_parent' id='comment_parent' value='0'/>
</div>
 
<div id="submitbox" class="left">
<input name="submit" type="submit" id="submit" class="button" tabindex="5" value="Enviar Comentario"/>
<input type="hidden" name="formInput"/>
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c903f7e2c4"/></p> <p class="antispam-group antispam-group-q" style="clear: both;">
<label>Current <a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="bcc5d9fcce">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script> <span class="required">*</span></label>
<input type="hidden" name="antspm-a" class="antispam-control antispam-control-a" value="2017"/>
<input type="text" name="antspm-q" class="antispam-control antispam-control-q" value="4.3" autocomplete="off"/>
</p>
<p class="antispam-group antispam-group-e" style="display: none;">
<label>Leave this field empty</label>
<input type="text" name="antspm-e-email-url-website" class="antispam-control antispam-control-e" value="" autocomplete="off"/>
</p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Recibir un email con los siguientes comentarios a esta entrada.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Recibir un email con cada nueva entrada.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="17"/></p> </div>
</form>
</div>
 
</div>
</div>
 
 
<div class="col2">
<ul id="sidebar">
<li class="block widget widget_categories" id="categories-3"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Categorías</span></h4></div> <ul>
<li class="cat-item cat-item-13"><a href="http://www.javiergutierrezchamorro.com/category/actualidad" title="Actualidad, última hora, noticias y novedades">Actualidad</a> (32)
</li>
<li class="cat-item cat-item-510"><a href="http://www.javiergutierrezchamorro.com/category/afeitado" title="Afeitado clásico, convencional, lociones, jabones, brochas, maquinillas, cuchillas, cuidado personal y otros productos">Afeitado</a> (29)
</li>
<li class="cat-item cat-item-514"><a href="http://www.javiergutierrezchamorro.com/category/amigos" title="Amigos, colaboradores, guestposting, artículos cedidos, post patrocinados">Amigos</a> (29)
</li>
<li class="cat-item cat-item-12"><a href="http://www.javiergutierrezchamorro.com/category/arte" title="Pintura, escultura, fotografía, modelos, multimedia y otras disciplinas artísticas en general">Arte</a> (81)
</li>
<li class="cat-item cat-item-1"><a href="http://www.javiergutierrezchamorro.com/category/ciencia" title="Ciencias formales y ciencias naturales">Ciencia</a> (88)
</li>
<li class="cat-item cat-item-2"><a href="http://www.javiergutierrezchamorro.com/category/cine" title="Películas, cine, directores, guionistas, actores, actrices, estrenos, celebrities">Cine</a> (180)
</li>
<li class="cat-item cat-item-3"><a href="http://www.javiergutierrezchamorro.com/category/coches" title="Automóviles, motocicletas, tunning, Fórmula 1, Fórmula-E, rallys y otros deportes del motor">Coches</a> (235)
</li>
<li class="cat-item cat-item-511"><a href="http://www.javiergutierrezchamorro.com/category/escritura" title="Elementos y de escritura, plumas estilográficas, grafos, artículos de escritorio, cartuchos, tintas, conversores a émbolo y otros accesorios">Escritura</a> (29)
</li>
<li class="cat-item cat-item-4"><a href="http://www.javiergutierrezchamorro.com/category/filosofia" title="Filosofía, humanismo, y otros pensamientos  y pensadores">Filosofía</a> (19)
</li>
<li class="cat-item cat-item-513"><a href="http://www.javiergutierrezchamorro.com/category/hogar" title="Decoración, menaje, ropa de cama, y útiles para la casa">Hogar</a> (46)
</li>
<li class="cat-item cat-item-14"><a href="http://www.javiergutierrezchamorro.com/category/humor" title="Chistes, gracias, tonterías variadas, y humor en general">Humor</a> (82)
</li>
<li class="cat-item cat-item-5"><a href="http://www.javiergutierrezchamorro.com/category/informatica" title="Informática, tecnología, TIC, i+D+i, ...">Informática</a> (1.414)
<ul class='children'>
<li class="cat-item cat-item-507"><a href="http://www.javiergutierrezchamorro.com/category/informatica/hardware" title="Hardware de consumo y empresarial. Electrónica y gadgets">Hardware</a> (130)
</li>
<li class="cat-item cat-item-506"><a href="http://www.javiergutierrezchamorro.com/category/informatica/internet" title="Internet, portales, servicios, P2P, descargas, ...">Internet</a> (647)
</li>
<li class="cat-item cat-item-504"><a href="http://www.javiergutierrezchamorro.com/category/informatica/juegos" title="Juegos de ordenador, PC, consolas, arcade, online y móviles">Juegos</a> (110)
</li>
<li class="cat-item cat-item-501"><a href="http://www.javiergutierrezchamorro.com/category/informatica/noticias" title="Novedades, presentaciones, rumores, noticias, y lanzamientos">Noticias</a> (115)
</li>
<li class="cat-item cat-item-502"><a href="http://www.javiergutierrezchamorro.com/category/informatica/programacion" title="Programación general, plataformas (Windows, DOS, Linux, recreativas, móviles, web, ...), y lenguajes de programación (C/C++, PHP, Javascript, HTML, Flash, BASIC, Pascal, ...)">Programación</a> (492)
</li>
<li class="cat-item cat-item-505"><a href="http://www.javiergutierrezchamorro.com/category/informatica/retro" title="Retroinformática y vintage, desde el inicio de la informática">Retro</a> (281)
</li>
<li class="cat-item cat-item-503"><a href="http://www.javiergutierrezchamorro.com/category/informatica/software" title="Análisis de software y aplicaciones y de nuevas versiones o actualizaciones">Software</a> (789)
</li>
</ul>
</li>
<li class="cat-item cat-item-512"><a href="http://www.javiergutierrezchamorro.com/category/juguetes" title="Muñecos, figuras de acción, slot, maquetas, modelismo, rol, juegos de mesa y otros juegos juguetes">Juguetes</a> (17)
</li>
<li class="cat-item cat-item-6"><a href="http://www.javiergutierrezchamorro.com/category/libros" title="Libros, autores, escritores, novelas, cuentos, antologías y literatura en general">Libros</a> (91)
</li>
<li class="cat-item cat-item-509"><a href="http://www.javiergutierrezchamorro.com/category/moda" title="Moda, textil, calzado y complementos de vestir para hombre y mujer">Moda</a> (74)
</li>
<li class="cat-item cat-item-7"><a href="http://www.javiergutierrezchamorro.com/category/musica" title="Grupos, bandas, solistas, compositores, productores, remezclas, singles, discos, vinilos LP, CD, videoclips, DJ, conciertos, canciones, temas, cortes, ...">Música</a> (62)
</li>
<li class="cat-item cat-item-8"><a href="http://www.javiergutierrezchamorro.com/category/personal" title="Íntimo y personal, no obstante con ciertos límites">Personal</a> (223)
</li>
<li class="cat-item cat-item-9"><a href="http://www.javiergutierrezchamorro.com/category/reflexiones" title="Pensamientos, reflexiones y análisis más o menos personales que desean ser compartidos">Reflexiones</a> (137)
</li>
<li class="cat-item cat-item-508"><a href="http://www.javiergutierrezchamorro.com/category/relojes" title="Horología, guardatiempos, relojes de pared, de pulsera, de bolsillo, de mesa, analógicos, digitales, de cuarzo, mecánicos, japoneses, suizos, chinos, modernos, antiguos, ...">Relojes</a> (177)
</li>
<li class="cat-item cat-item-10"><a href="http://www.javiergutierrezchamorro.com/category/television" title="Programación, series de TV, documentales, presentadores, concursos y todo lo que pueda salir de la caja tonta">Televisión</a> (161)
</li>
<li class="cat-item cat-item-11"><a href="http://www.javiergutierrezchamorro.com/category/varios" title="Cajón de sastre donde entra todo lo que no cabe en otras categorías, o que no tenga una temática clara">Varios</a> (208)
</li>
</ul>
</div></div></div></div></div></div> </div></li><li class="block widget widget_search" id="search-3"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Búsqueda</span></h4></div>
 
<form method="get" id="searchform" action="http://www.javiergutierrezchamorro.com/">
<input type="search" name="s" id="searchbox" required class="searchfield" value="" placeholder="Buscar"/>
<input type="submit" value="Go" class="searchbutton"/>
</form>
 </div></div></div></div></div></div> </div></li><li class="block widget widget_advancedrandomposts" id="advancedrandomposts-4"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Entrada aleatoria</span></h4></div><ul class="advanced-random-posts"><li><a href="http://www.javiergutierrezchamorro.com/corsaight-rider-el-corsa-fant-stico/356" title="Corsaight Rider (El Corsa Fantástico)">Corsaight Rider (El Corsa Fantástico)</a></li>
</ul></div></div></div></div></div></div> </div></li><li class="block widget widget_recent_comments" id="recent-comments-3"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Últimos comentarios</span></h4></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='http://www.javiergutierrezchamorro.com' rel='external nofollow' class='url'>Javier Gutiérrez Chamorro (Guti)</a></span> en <a href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138#comment-69376">Uptime 2 para DOS</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.javiergutierrezchamorro.com' rel='external nofollow' class='url'>Javier Gutiérrez Chamorro (Guti)</a></span> en <a href="http://www.javiergutierrezchamorro.com/protocolo-dcf/3146#comment-69375">Protocolo DCF</a></li><li class="recentcomments"><span class="comment-author-link">bianamaran</span> en <a href="http://www.javiergutierrezchamorro.com/uptime-2-dos/3138#comment-69374">Uptime 2 para DOS</a></li><li class="recentcomments"><span class="comment-author-link">Robinson Paul Molina Coronado</span> en <a href="http://www.javiergutierrezchamorro.com/protocolo-dcf/3146#comment-69373">Protocolo DCF</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://lab.fawno.com' rel='external nofollow' class='url'>Fernando</a></span> en <a href="http://www.javiergutierrezchamorro.com/protocolo-dcf/3146#comment-69372">Protocolo DCF</a></li><li class="recentcomments"><span class="comment-author-link">bianamaran</span> en <a href="http://www.javiergutierrezchamorro.com/protocolo-dcf/3146#comment-69371">Protocolo DCF</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.javiergutierrezchamorro.com' rel='external nofollow' class='url'>Javier Gutiérrez Chamorro (Guti)</a></span> en <a href="http://www.javiergutierrezchamorro.com/protocolo-dcf/3146#comment-69370">Protocolo DCF</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.javiergutierrezchamorro.com' rel='external nofollow' class='url'>Javier Gutiérrez Chamorro (Guti)</a></span> en <a href="http://www.javiergutierrezchamorro.com/casio-dw-5600c/2985#comment-69369">Casio DW-5600C</a></li><li class="recentcomments"><span class="comment-author-link">Francisco Rodriguez</span> en <a href="http://www.javiergutierrezchamorro.com/casio-dw-5600c/2985#comment-69368">Casio DW-5600C</a></li><li class="recentcomments"><span class="comment-author-link">bianamaran</span> en <a href="http://www.javiergutierrezchamorro.com/protocolo-dcf/3146#comment-69367">Protocolo DCF</a></li></ul></div></div></div></div></div></div> </div></li><li class="block widget widget_text" id="text-2"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Enlaces</span></h4></div> <div class="textwidget"><p><a href="http://www.javiergutierrezchamorro.com">Principal</a><br/>
<a href="http://www.javiergutierrezchamorro.com/contacta-conmigo">Contacta conmigo</a></p>
<p>Generales<br/>
<a href="http://www.javiergutierrezchamorro.com/acerca-del-autor">Acerca del autor</a><br/>
<a href="http://www.javiergutierrezchamorro.com/anunciarse">Anunciarse aquí</a><br/>
<a href="http://nikkhokkho.sourceforge.net" target="_blank" rel="noopener">Mi software</a><br/>
<a href="https://www.amazon.es/s/ref=dp_byline_sr_ebooks_1/?tag=gutibitacor0c-21&#038;search-alias=digital-text&#038;field-author=Javier+Gutiérrez+Chamorro" target="_blank" rel="noopener">Mis libros en Amazon</a><br/>
<a href="https://www.facebook.com/bitacoraguti/" target="_blank" rel="noopener">Página pública en Facebook</a><br/>
<a href="https://www.facebook.com/javier.gutierrez.chamorro.bitacora" target="_blank" rel="noopener">Perfil en Facebook</a><br/>
<a href="https://twitter.com/bitacoraguti" target="_blank" rel="noopener">Sígueme en Twitter</a><br/>
<a href="https://es.linkedin.com/in/javiergutierrezchamorro" target="_blank" rel="noopener">Perfil en Linkedin</a><br/>
<a href="https://www.sourceforge.net/projects/nikkhokkho" target="_blank" rel="noopener">Página en Sourceforge</a><br/>
<a href="https://es.youtube.com/nikkho" target="_blank" rel="noopener">Videos en Youtube</a><br/>
<a href="http://www.javiergutierrezchamorro.com/date/2004">Hemeroteca</a><br/>
<a href="http://translate.google.com/translate?u=http%3A%2F%2Fwww.javiergutierrezchamorro.com&#038;langpair=es%7Cen&#038;hl=es" target="_blank" rel="noopener">Translate to english</a><br/>
<a href="http://www.google.com/gwt/n?u=http%3A%2F%2Fwww.javiergutierrezchamorro.com" target="_blank" rel="noopener">Versión WAP</a></p>
<p>Otras bitácoras<br/>
<a href="https://bianamaran.blogspot.com" target="_blank" rel="noopener">Bia Namaran</a><br/>
<a href="http://www.polimalo.com" target="_blank" rel="noopener">David (Polimalo)</a><br/>
<a href="http://www.duraderos.com" target="_blank" rel="noopener">Duraderos</a><br/>
<a href="http://www.landingshort.com" target="_blank" rel="noopener">Joan (Landing Short)</a><br/>
<a href="https://estilograficabcn.blogspot.com" target="_blank" rel="noopener">José (Amics de l&#8217;estilogràfica)</a><br/>
<a href="http://www.planetacodigo.com" target="_blank" rel="noopener">Planeta Código</a><br/>
<a href="https://revistaordenadores.blogspot.com" target="_blank" rel="noopener">Revista Ordenadores</a><br/>
<a href="http://www.revistarelojes.com" target="_blank" rel="noopener">Revista Relojes</a><br/>
<a href="http://www.zonacasio.com" target="_blank" rel="noopener">Zona Casio</a></p>
<p>Otros</p>
</div>
</div></div></div></div></div></div> </div></li> <li class="block">
<div class="box">
<div class="titlewrap"><h4><span>Otros</span></h4></div>
<div class="wrapleft">
<div class="wrapright">
<div class="tr">
<div class="bl">
<div class="tl">
<div class="br the-content">
<ul>
<br/><br/><center>
 
 
 
 
</center>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
</ul>
</div>
 
</div>
</div>
</div>
 
</div>
</div>
 
 
<div id="footer">
 
<div class="block-content">
<div class="copyright">
<p>
<a href="https://www.creativecommons.org/licenses/by/4.0/deed.es" target="_blank">Creative Commons</a> (cc) 2004-2017 Javier Guti&eacute;rrez Chamorro (Guti) - P&aacute;gina generada en 0,295 segundos
</p>
</div>
</div>
 
</div>
 
</div>
 
<script type="text/javascript">
  /* <![CDATA[ */
    var isIE6 = false; /* <- do not change! */
    var isIE = false; /* <- do not change! */
    var lightbox = false;/* <- do not change! */
  /* ]]> */
  </script>
<!--[if lte IE 6]> <script type="text/javascript"> isIE6 = true; isIE = true; </script> <![endif]-->
<!--[if gte IE 7]> <script type="text/javascript"> isIE = true; </script> <![endif]-->
 
<div class="cdp-cookies-alerta  cdp-solapa-ocultar cdp-cookies-textos-izq cdp-cookies-tema-gris">
<div class="cdp-cookies-texto">
<h4 style="font-size:15px !important;line-height:15px !important">Uso de cookies</h4><p style="font-size:12px !important;line-height:12px !important">Esta web utiliza cookies para mejorar la mejor experiencia de usuario. Si continúas navegando estás dandos tu consentimiento para la aceptación de las mismas y la aceptación de la <a href="http://www.javiergutierrezchamorro.com/politica-de-cookies" style="font-size:12px !important;line-height:12px !important">política de cookies</a>, pincha el enlace para más información.</p>
<a href="javascript:;" class="cdp-cookies-boton-cerrar">ACEPTAR</a>
</div>
<a class="cdp-cookies-solapa">Aviso de cookies</a>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.javiergutierrezchamorro.com\/uptime-2-dos\/3138":3138};
	</script>
<div id="sharing_email" style="display: none;">
<form action="/uptime-2-dos/3138" method="post">
<label for="target_email">Enviar a dirección de correo electrónico</label>
<input type="email" name="target_email" id="target_email" value=""/>
<label for="source_name">Su Nombre</label>
<input type="text" name="source_name" id="source_name" value=""/>
<label for="source_email">Tu dirección de correo electrónico</label>
<input type="email" name="source_email" id="source_email" value=""/>
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="Este campo sirve de validación y no debería cambiarse"/>
<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
<img style="float: right; display: none" class="loading" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16"/>
<input type="submit" value="Enviar correo electrónico" class="sharing_send"/>
<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancelar</a>
<div class="errors errors-1" style="display: none;">
La entrada no fue enviada. ¡Comprueba tus direcciones de correo electrónico! </div>
<div class="errors errors-2" style="display: none;">
Error en la comprobación de email. Por favor, vuelve a intentarlo </div>
<div class="errors errors-3" style="display: none;">
Lo sentimos, tu blog no puede compartir entradas por correo electrónico. </div>
</form>
</div>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/anti-spam/js/anti-spam-4.3.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201731'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"http:\/\/www.javiergutierrezchamorro.com\/wp-content\/plugins\/wp-postratings","ajax_url":"http:\/\/www.javiergutierrezchamorro.com\/wp-admin\/admin-ajax.php","text_wait":"Por favor, valora solo 1 elemento cada vez.","image":"stars","image_ext":"gif","max":"5","show_loading":"0","show_fading":"0","custom":"0"};
var ratings_mouseover_image=new Image();ratings_mouseover_image.src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.84'></script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-syntax/js/wp-syntax.js?ver=1.1'></script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.2.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201731.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.2.1',blog:'115063527',post:'3138',tz:'2',srv:'www.javiergutierrezchamorro.com'} ]);
	_stq.push([ 'clickTrackerInit', '115063527', '3138' ]);
</script>
<script type="text/javascript">
	var aLinks = document.getElementsByTagName('a');
	var iLinksLen = aLinks.length;
	
	for (var iLink = 0; iLink < iLinksLen; iLink++)
	{
		var sLink = aLinks[iLink].href;
		//console.log(sLink);
		
		//eBay affiliates
		if ((sLink.indexOf('rover.ebay.com') !== -1) && (sLink.indexOf('pub=5575153231') === -1))
		{
			sLink = ParamReplace(sLink, 'pub', '5575153231');	
		}
		//eBay.es
		else if ((sLink.indexOf('ebay.es') !== -1) && (sLink.indexOf('pub=5575153231') === -1))
		{
			sLink = '//rover.ebay.com/rover/1/1185-53479-19255-0/1?ff3=4&pub=5575153231&toolid=10001&campid=5337807603&customid=&mpre=' + escape(sLink);
		}
		//eBay.com
		else if ((sLink.indexOf('ebay.com') !== -1) && (sLink.indexOf('pub=5575153231') === -1))
		{
			sLink = '//rover.ebay.com/rover/1/711-53200-19255-0/1?ff3=4&pub=5575153231&toolid=10001&campid=5337807603&customid=&mpre=' + escape(sLink);
		}
		//Amazon.es
		else if ((sLink.indexOf('amazon.es') !== -1) && (sLink.indexOf('tag=gutibitacor0c-21') === -1))
		{
			sLink = ParamReplace(sLink, 'tag', 'gutibitacor0c-21');
		}
		//Meranom.com
		else if ((sLink.indexOf('meranom.com') !== -1) && (sLink.indexOf('tracking=54a2563b3980a') === -1))
		{
			sLink = ParamReplace(sLink, 'tracking', '54a2563b3980a');
		}
		//Dreamhost.com
		else if ((sLink.indexOf('dreamhost.com/r.cgi') !== -1) && (sLink.indexOf('1561838') === -1))
		{
			sLink = ParamReplace(sLink, '', '1561838');
		}
		//DigitalOcean.com
		else if ((sLink.indexOf('dreamhost.com/r.cgi') !== -1) && (sLink.indexOf('bcae4f3b87e0') === -1))
		{
			sLink = ParamReplace(sLink, 'refcode', 'bcae4f3b87e0');
		}
		aLinks[iLink].href = sLink;
	}
	
	
	
	function ParamReplace(uri, key, value)
	{
		var re = new RegExp("([?|&])" + key + "=.*?(&|#|$)", "i");
		if (uri.match(re))
		{
			return uri.replace(re, '$1' + key + "=" + value + '$2');
		}
		else
		{
			var hash =  '';
			if( uri.indexOf('#') !== -1 )
			{
				hash = uri.replace(/.*#/, '#');
				uri = uri.replace(/#.*/, '');
			}
			var separator = uri.indexOf('?') !== -1 ? "&" : "?";    
			return uri + separator + key + "=" + value + hash;
		}
	}
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-57056-1', 'auto');
	ga('send', 'pageview');
</script>
</body>
</html>
