﻿<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="es">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Visual Basic .NET no es Basic | Bitácora de Javier Gutiérrez Chamorro (Guti) </title>
<meta name="dc.title" content="Visual Basic .NET no es Basic | Bitácora de Javier Gutiérrez Chamorro (Guti) "/>
<meta name="dc.subject" content="guti, nikkho, weblog, blog, bitácora, javier gutiérrez chamorro, javier gutiérrez, javier, gutiérrez, chamorro, diario, reflexión, reflexiones, crónica, crónicas, artículo, artículos, relato, relatos, opinión, opiniones, noticia, noticias, j.g.ch, jgch, j.g.c, jgc, j.g, jg"/>
<meta name="dc.description" content="Mi nombre es Javier Gutiérrez Chamorro (Guti). Tengo 41 años, y también se me conoce por Guti o Nikkho. Los que seáis fieles a este blog podréis ir leyendo desde aquí mis reflexiones a modo de crónica sobre varios temas de mi interés. Si te gusta la tecnología, la informática, la programación, los coches, o la filosofía, entre otras cosas, seguramente encontrarás extremadamente atrayente este sitio."/>
<meta name="author" content="Javier Gutiérrez Chamorro (Guti)"/>
<meta name="dc.creator" content="Javier Gutiérrez Chamorro (Guti)"/>
<meta name="dc.type" content="weblog"/>
<meta name="dc.type" content="blog"/>
<meta name="resource-type" content="document"/>
<meta name="dc.format" scheme="IMT" content="text/html"/>
<meta name="dc.source" scheme="URI" content="http://www.javiergutierrezchamorro.com"/>
<meta name="dc.language" scheme="RFC1766" content="es"/>
<meta http-equiv="Content-Language" content="es"/>
<meta name="dc.coverage" content="global"/>
<meta name="distribution" content="GLOBAL"/>
<meta name="dc.rights" content="Creative Commons (cc) 2004-2017 Javier Gutiérrez Chamorro (Guti)"/>
<meta name="copyright" content="Creative Commons (cc) 2004-2017 Javier Gutiérrez Chamorro (Guti)"/>
<meta name="robots" content="ALL,INDEX,FOLLOW,ARCHIVE"/>
<meta name="revisit-after" content="1 days"/>
<meta name="ICBM" content="041.42578, 002.186203"/>
<meta name="apple-mobile-web-app-capable" content="yes"/>
<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=0.1, maximum-scale=10, user-scalable=yes"/>
<link rel="alternate" type="application/x-opera-widgets" title="Bitácora de Javier Gutiérrez Chamorro (Guti)" href="http://widgets.opera.com/widgetize/Feed%20Reader/Advanced/?serve&amp;skin=skin6&amp;widgetname=Bit%C3%A1cora%20de%20Javier%20Guti%C3%A9rrez%20Chamorro%20%28Guti%29&amp;url=http%3A%2F%2Ffeeds.feedburner.com%2Fjaviergutierrezchamorro&amp;rel=myopera&amp;ref="/>
<link rel="alternate" type="application/rss+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) RSS Feed" href="http://www.javiergutierrezchamorro.com/feed/rss"/>
<link rel="alternate" type="application/atom+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) Atom Feed" href="http://www.javiergutierrezchamorro.com/feed/atom"/>
<link rel="alternate" type="application/rss+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) RDF Feed" href="http://www.javiergutierrezchamorro.com/feed/rdf"/>
<link rel="alternate" type="application/rss+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) RSS Feed de los comentarios" href="http://www.javiergutierrezchamorro.com/comments/feed/"/>
<link rel="pingback" href="http://www.javiergutierrezchamorro.com/xmlrpc.php"/>
<link rel="shortcut icon" href="http://www.javiergutierrezchamorro.com/wp-content/themes/guti/favicon.ico?x34527"/>
 
<link rel="canonical" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503"/>
<link rel="publisher" href="https://plus.google.com/108304469897790042618/posts"/>
<meta property="og:locale" content="es_ES"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Visual Basic .NET no es Basic | Bitácora de Javier Gutiérrez Chamorro (Guti)"/>
<meta property="og:description" content="Mucho se ha hablado de la revolución de Visual Basic .NET comparado con Visual Basic. A punto está de aparecer Visual Basic .NET 2005, y ahora Visual Basic está totalmente orientado a objetos. Lo que ocurre es que mientras que Visual Basic, era una extensión de BASIC (Beginner&#8217;s All-purpose Symbolic Instruction Code), Visual Basic .NET, &hellip;"/>
<meta property="og:url" content="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503"/>
<meta property="og:site_name" content="Bitácora de Javier Gutiérrez Chamorro (Guti)"/>
<meta property="article:publisher" content="https://www.facebook.com/javier.gutierrez.chamorro"/>
<meta property="article:section" content="Informática"/>
<meta property="article:published_time" content="2005-04-18T20:10:49+02:00"/>
<meta property="fb:app_id" content="254712291385660"/>
<meta property="og:image" content="http://www.javiergutierrezchamorro.com/wp-content/uploads/2005/04/visual_basic_no_es_basic.png"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:description" content="Mucho se ha hablado de la revolución de Visual Basic .NET comparado con Visual Basic. A punto está de aparecer Visual Basic .NET 2005, y ahora Visual Basic está totalmente orientado a objetos. Lo que ocurre es que mientras que Visual Basic, era una extensión de BASIC (Beginner&#8217;s All-purpose Symbolic Instruction Code), Visual Basic .NET, [&hellip;]"/>
<meta name="twitter:title" content="Visual Basic .NET no es Basic | Bitácora de Javier Gutiérrez Chamorro (Guti)"/>
<meta name="twitter:site" content="@bitacoraguti"/>
<meta name="twitter:image" content="http://www.javiergutierrezchamorro.com/wp-content/uploads/2005/04/visual_basic_no_es_basic.png"/>
<meta name="twitter:creator" content="@bitacoraguti"/>
 
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="stylesheet" href="http://www.javiergutierrezchamorro.com/wp-content/themes/guti/style.css"/>
<link rel="stylesheet" href="http://www.javiergutierrezchamorro.com/wp-content/themes/guti/options/side-green.css"/>
<link rel="stylesheet" href="http://www.javiergutierrezchamorro.com/wp-content/themes/guti/options/content-white.css"/>
<style type="text/css">#header-wrap{background:transparent url("http://www.javiergutierrezchamorro.com/wp-content/uploads/header-fire-green.jpg") repeat center top;}.block-content{width:95%;max-width:95%;}#pagetitle{font-size:75%;}</style>
<!--[if lte IE 6]>
<style type="text/css" media="screen">
 @import "http://www.javiergutierrezchamorro.com/wp-content/themes/guti/ie6.css";
</style>
<![endif]-->
<link rel="alternate" type="application/rss+xml" title="Bitácora de Javier Gutiérrez Chamorro (Guti) &raquo; Visual Basic .NET no es Basic RSS de los comentarios" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503/feed"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.javiergutierrezchamorro.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='front-estilos-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/asesor-cookies-para-la-ley-en-espana/html/front/estilos.css?ver=4.7.3' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-postratings-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.84' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-pagenavi-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-syntax-css-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-syntax/css/wp-syntax.css?ver=1.1' type='text/css' media='all'/>
<link rel='stylesheet' id='social-logos-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.7.1' type='text/css' media='all'/>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cdp_cookies_info = {"url_plugin":"http:\/\/www.javiergutierrezchamorro.com\/wp-content\/plugins\/asesor-cookies-para-la-ley-en-espana\/plugin.php","url_admin_ajax":"http:\/\/www.javiergutierrezchamorro.com\/wp-admin\/admin-ajax.php","comportamiento":"cerrar","posicion":"inferior","layout":"ventana"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/asesor-cookies-para-la-ley-en-espana/html/front/principal.js?ver=4.7.3'></script>
<link rel='https://api.w.org/' href='http://www.javiergutierrezchamorro.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.javiergutierrezchamorro.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.javiergutierrezchamorro.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.7.3"/>
<link rel='shortlink' href='http://www.javiergutierrezchamorro.com/?p=503'/>
<link rel="alternate" type="application/json+oembed" href="http://www.javiergutierrezchamorro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.javiergutierrezchamorro.com%2Fvisual-basic-net-no-es-basic%2F503"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.javiergutierrezchamorro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.javiergutierrezchamorro.com%2Fvisual-basic-net-no-es-basic%2F503&#038;format=xml"/>
<style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important;}</style>
</head>
<body class="inner">
 
<div id="page" class="with-sidebar">
 
<div id="header-wrap">
<div id="header" class="block-content">
<div id="pagetitle" class="clearfix">
<h1 class="logo"><a href="http://www.javiergutierrezchamorro.com">Bitácora de Javier Gutiérrez Chamorro (Guti)</a></h1>
<h4>Mi nombre es Javier Gutiérrez Chamorro (Guti). Tengo 41 años, y también se me conoce por Guti o Nikkho.</h4>
</div>
</div>
</div>
 
 
<div id="main-wrap1">
<div id="main-wrap2">
 
<div id="main" class="block-content clearfix">
<div class="mask-main rightdiv">
<div class="mask-left">
 
<div class="col1">
<div id="main-content">
<div class="navigation clearfix">
<div class="alignleft">&laquo; <a href="http://www.javiergutierrezchamorro.com/shannon-elizabeth/502" rel="prev">Shannon Elizabeth</a></div>
<div class="alignright"><a href="http://www.javiergutierrezchamorro.com/art-culos-comentados-y-traducidos/504" rel="next">Artículos comentados y traducidos</a> &raquo;</div>
</div>
 
<div id="post-503" class="post-503 post type-post status-publish format-standard hentry category-informatica category-programacion category-software">
<h2 class="post-title">Visual Basic .NET no es Basic</h2> <div id="post-ratings-503" class="post-ratings" itemscope itemtype="http://schema.org/Article" data-nonce="b0a833dace"><img id="rating_503_1" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_on.gif?x34527" alt="1 Estrella" title="1 Estrella" onmouseover="current_rating(503, 1, '1 Estrella');" onmouseout="ratings_off(3, 3, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/><img id="rating_503_2" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_on.gif?x34527" alt="2 Estrellas" title="2 Estrellas" onmouseover="current_rating(503, 2, '2 Estrellas');" onmouseout="ratings_off(3, 3, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/><img id="rating_503_3" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_on.gif?x34527" alt="3 Estrellas" title="3 Estrellas" onmouseover="current_rating(503, 3, '3 Estrellas');" onmouseout="ratings_off(3, 3, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/><img id="rating_503_4" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_off.gif?x34527" alt="4 Estrellas" title="4 Estrellas" onmouseover="current_rating(503, 4, '4 Estrellas');" onmouseout="ratings_off(3, 3, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/><img id="rating_503_5" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_off.gif?x34527" alt="5 Estrellas" title="5 Estrellas" onmouseover="current_rating(503, 5, '5 Estrellas');" onmouseout="ratings_off(3, 3, 0);" onclick="rate_post();" onkeypress="rate_post();" style="cursor: pointer; border: 0px;"/> (<strong>205</strong> votes, average: <strong>2,96</strong> out of 5)<br/><span class="post-ratings-text" id="ratings_503_text"></span><meta itemprop="headline" content="Visual Basic .NET no es Basic"/><meta itemprop="description" content="Mucho se ha hablado de la revoluci&oacute;n de Visual Basic .NET comparado con Visual Basic.A punto est&aacute; de aparecer Visual Basic .NET 2005, y ahora Visual Basic est&aacute; totalmente orientado a objetos.Lo que oc..."/><meta itemprop="datePublished" content="2005-04-18T20:10:49+00:00"/><meta itemprop="dateModified" content="2005-04-18T20:10:49+00:00"/><meta itemprop="url" content="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503"/><meta itemprop="author" content="Javier Gutiérrez Chamorro (Guti)"/><meta itemprop="mainEntityOfPage" content="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503"/><div style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Bitácora de Javier Gutiérrez Chamorro (Guti)"/><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""/></div></div><div style="display: none;" itemprop="aggregateRating" itemscope itemtype="http://schema.org/AggregateRating"><meta itemprop="bestRating" content="5"/><meta itemprop="worstRating" content="1"/><meta itemprop="ratingValue" content="2.96097560976"/><meta itemprop="ratingCount" content="205"/></div></div> <script type="text/javascript">google_ad_client="ca-pub-3625063062589476"; google_ad_slot="8395655704"; google_ad_width=728; google_ad_height=90;</script><script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script><br/><br/> <div class="post-content clearfix">
<p>Mucho se ha hablado de la revolución de <a href="http://www.microsoft.com/vbasic" target="_blank">Visual Basic .NET</a> comparado con Visual Basic.</p>
<p>A punto está de aparecer Visual Basic .NET 2005, y ahora Visual Basic está totalmente orientado a objetos.</p>
<p>Lo que ocurre es que mientras que Visual Basic, era una extensión de <a href="http://en.wikipedia.org/wiki/BASIC_programming_language" target="_blank">BASIC (Beginner&#8217;s All-purpose Symbolic Instruction Code)</a>, Visual Basic .NET, no es una extensión de BASIC ni de Visual Basic. Es otra cosa.</p>
<p>¿Por qué? Muy sencillo:</p>
<p>1) BASIC nunca ha tenido operadores de incremento (++) ni decremento (&#8211;). A lo sumo algunos dialectos incluían funciones para tal menester (<a href="http://www.powerbasic.com" target="_blank">PowerBasic</a> con su INCR y DECR).</p>
<p>2) En BASIC todas las variables han sido siempre sin tipo (Variant en terminología <a href="http://www.microsoft.es" target="_blank">Microsoft</a> reciente).</p>
<p>3) Las variables con tipo de BASIC, se pueden especificar con los modificadores de tipo (%, #, !, $, &#8230;).</p>
<p>4) BASIC acepta números de linea.</p>
<p>Los puntos anteriores, los cumple BASIC, y también sus dialectos evolucionados (GWBASIC, Quick Basic, Turbo Basic, PowerBasic, Visual Basic, &#8230;). Por contra, con Visual Basic .NET, no son ciertos.</p>
<p>En conclusión Visual Basic es un BASIC modernizado, con extensiones, y nuevas características, pero BASIC a la postre.</p>
<p>Visual Basic .NET es un lenguaje mucho más complejo y potente, pero no es ni Visual Basic ni BASIC.</p>
<p>Podríamos llamarlo BASIC#, ya que tiene en común con BASIC, lo mismo que C# con C.</p>
<p>No es descabellado pensar en lo necesario que es disponer de un entorno de desarrollo actualizado, pero basado en un lenguaje sencillo, como era el caso de Visual Basic.</p>
<p>Una herramienta ideal para el aprendizaje, y para emprender sin quebraderos de cabeza desarrollos sencillos. Creo que Microsoft debería sacar una nueva versión del Visual Basic tradicional. </p>
<p><a href="http://www.javiergutierrezchamorro.com/wp-content/uploads/2005/04/visual_basic_no_es_basic.png?x34527" target="_blank"><img src="http://www.javiergutierrezchamorro.com/wp-content/uploads/2005/04/visual_basic_no_es_basic.png?x34527" border="0" alt=""/></a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Compartir</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-503" class="share-facebook sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=facebook" target="_blank" title="Haz clic para compartir en Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-503" class="share-twitter sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=twitter" target="_blank" title="Haz clic para compartir en Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-503" class="share-linkedin sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=linkedin" target="_blank" title="Haz clic para compartir en LinkedIn"><span>LinkedIn</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>Más</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-503" class="share-google-plus-1 sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=google-plus-1" target="_blank" title="Haz clic para compartir en Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=reddit" target="_blank" title="Haz clic para compartir en Reddit"><span>Reddit</span></a></li><li class="share-end"></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=tumblr" target="_blank" title="Haz clic para compartir en Tumblr"><span>Tumblr</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-503" class="share-pinterest sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=pinterest" target="_blank" title="Haz clic para compartir en Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=email" target="_blank" title="Haz clic para enviar por correo electrónico a un amigo"><span>Correo electrónico</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503#print" target="_blank" title="Haz clic para imprimir"><span>Imprimir</span></a></li><li class="share-end"></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=pocket" target="_blank" title="Haz clic para compartir en Pocket"><span>Pocket</span></a></li><li class="share-skype"><a rel="nofollow" data-shared="sharing-skype-503" class="share-skype sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=skype" target="_blank" title="Compartir en Skype"><span>Skype</span></a></li><li class="share-end"></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="whatsapp://send?text=Visual%20Basic%20.NET%20no%20es%20Basic http%3A%2F%2Fwww.javiergutierrezchamorro.com%2Fvisual-basic-net-no-es-basic%2F503" target="_blank" title="Haz clic para compartir en WhatsApp"><span>WhatsApp</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon" href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503?share=telegram" target="_blank" title="Haz clic para compartir en Telegram"><span>Telegram</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Relacionado</em></h3>
</div> </div>
<p class="post-metadata">
Esta entrada se publicó el 18 de Abril de 2005, 20:10 y está guardada en <a href="http://www.javiergutierrezchamorro.com/category/informatica" rel="category tag">Informática</a>, <a href="http://www.javiergutierrezchamorro.com/category/informatica/programacion" rel="category tag">Programación</a>, <a href="http://www.javiergutierrezchamorro.com/category/informatica/software" rel="category tag">Software</a>. Puedes seguir las respuestas a esta entrada en <a href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503/feed" title="RSS 2.0">RSS 2.0</a>.
Puede ir hasta abajo y dejar una respuesta. No se permiten pings. </p>
<script type="text/javascript">google_ad_client="ca-pub-3625063062589476"; google_ad_slot="8395655704"; google_ad_width=728; google_ad_height=90;</script><script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script><br/><br/> </div>
 
<h3 class="comments">
6 Comments </h3>
 
<ul id="comments" class="clearfix">
 
<li class="comment even thread-even depth-1 with-avatar" id="comment-2402">
<div class="comment-mask regularcomment">
<div class="comment-main">
<div class="comment-wrap1">
<div class="comment-wrap2">
<div class="comment-head tiptrigger">
<p>
<a class="comment-id" href="#comment-2402">#1</a> by <b id="commentauthor-2402">xergio</b> on 19 de Abril de 2005 - 13:11 </p>
<p class="controls tip">
<a class="quote" title="Citar" href="javascript:void(0);"><span>Citar</span></a> </p>
</div>
<div class="comment-body clearfix" id="comment-body-2402">
<div class="avatar"><img alt='' src='http://0.gravatar.com/avatar/95a2e9b28737e771d321bf89f378da80?s=64&#038;d=mm&#038;r=x' srcset='http://0.gravatar.com/avatar/95a2e9b28737e771d321bf89f378da80?s=128&amp;d=mm&amp;r=x 2x' class='avatar avatar-64 photo' height='64' width='64'/></div>
<div class="comment-text"><p>A mi no me ha costado mucho aprender vb.net. Igual es porque ya sabía vb6, aprendí c#, y luego vb.net me parecía lo mismo que c# pero con la simplicidad de vb6 (qué pupurri). Pero si, de hecho los programadores \&quot;de toda la vida\&quot; de vb6 se han quejado porque microsoft va a dejar de dar soporte para este&#8230; normal, una parsona que lleva 15 años con basic a sus casi 50 tacos actuales, no está por la labor de dedicarse a aprender algo demasiado nuevo para él.</p>
</div>
<a id="comment-reply-2402"></a>
</div>
<script type="text/javascript">google_ad_client="ca-pub-3625063062589476"; google_ad_slot="8395655704"; google_ad_width=728; google_ad_height=90;</script><script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script><br/><br/>
</div>
</div>
</div>
</div>
</li> 
 
<li class="comment odd alt thread-odd thread-alt depth-1 with-avatar" id="comment-2403">
<div class="comment-mask regularcomment">
<div class="comment-main">
<div class="comment-wrap1">
<div class="comment-wrap2">
<div class="comment-head tiptrigger">
<p>
<a class="comment-id" href="#comment-2403">#2</a> by <b id="commentauthor-2403">luis</b> on 19 de Abril de 2005 - 20:11 </p>
<p class="controls tip">
<a class="quote" title="Citar" href="javascript:void(0);"><span>Citar</span></a> </p>
</div>
<div class="comment-body clearfix" id="comment-body-2403">
<div class="avatar"><img alt='' src='http://0.gravatar.com/avatar/?s=64&#038;d=mm&#038;r=x' srcset='http://0.gravatar.com/avatar/?s=128&amp;d=mm&amp;r=x 2x' class='avatar avatar-64 photo avatar-default' height='64' width='64'/></div>
<div class="comment-text"><p>hombre, yo estoy con xergio, vb.net es muy sencillo de aprender, otra cosa es que la gente no este por la labor de aprender lenguajes nuevos. De cualquier forma, creo que todo son ventajas al pasarse de VB6 a .NET, el primero tiene una orientación a objetos &quot;de juguete&quot;.Además, basic sigue siendo basic, la sintaxis es la misma, solo que ahora tienes &quot;cuatro o cinco&quot; cosas más que aprenderte, pero que posiblemente te resolverán la vida en cuanto sepas utilizarlas. Y ni que decir tiene que una vez aprendido VB.NET es trivial pasarse a C#, con matices, y que ya es posible escribir aplicaciones .NET tanto para linux como para windows. No se, creo que .NET es una opción muy pero que muy acertada, se mire por donde se mire.</p>
</div>
<a id="comment-reply-2403"></a>
</div>
<div id="adsadpv49480"></div><script type="text/javascript">var adpv_client="49480"; var adpv_width=728; var adpv_height=90; var adpv_container_id="adsadpv49480";</script><script type="text/javascript" src="http://ads.adpv.com/ads.js"></script><br/><br/>
</div>
</div>
</div>
</div>
</li> 
 
<li class="comment byuser comment-author-guti bypostauthor even thread-even depth-1 with-avatar" id="comment-2404">
<div class="comment-mask admincomment">
<div class="comment-main">
<div class="comment-wrap1">
<div class="comment-wrap2">
<div class="comment-head tiptrigger">
<p>
<a class="comment-id" href="#comment-2404">#3</a> by <span class="with-tooltip"><a class="comment-author" id="commentauthor-2404" href="http://www.javiergutierrezchamorro.com">Javier Gutiérrez Chamorro (Guti)</a></span> on 19 de Abril de 2005 - 21:27 </p>
<p class="controls tip">
<a class="quote" title="Citar" href="javascript:void(0);"><span>Citar</span></a> </p>
</div>
<div class="comment-body clearfix" id="comment-body-2404">
<div class="avatar"><img alt='' src='http://0.gravatar.com/avatar/fef7e7ec3b5cabd126f26228e7ae8022?s=64&#038;d=mm&#038;r=x' srcset='http://0.gravatar.com/avatar/fef7e7ec3b5cabd126f26228e7ae8022?s=128&amp;d=mm&amp;r=x 2x' class='avatar avatar-64 photo' height='64' width='64'/></div>
<div class="comment-text"><p>Está claro que Visual Basic.NET no es complicado de aprender, si se viene de Visual Basic, y cualquier otro lenguaje que utilice la jerarquía de clases del .NET framework.</p>
<p>En efecto, tenéis razón en que las ganas y la capacidad de aprender, son fundamentales para conseguir congerle el truco.</p>
<p>Lo que quiero decir, es que me parece una infraestructura demasiado compleja para proyectos sencillos, y más complicado de aprender que VB, aunque esto no quiera decir que sea difícil.</p>
</div>
<a id="comment-reply-2404"></a>
</div>
<br/><br/>
</div>
</div>
</div>
</div>
</li> 
 
<li class="comment odd alt thread-odd thread-alt depth-1 with-avatar" id="comment-5482">
<div class="comment-mask regularcomment">
<div class="comment-main">
<div class="comment-wrap1">
<div class="comment-wrap2">
<div class="comment-head tiptrigger">
<p>
<a class="comment-id" href="#comment-5482">#4</a> by <span class="with-tooltip"><a class="comment-author" id="commentauthor-5482" href="http://www.aktive.com.ar">Jonatan</a></span> on 20 de Mayo de 2011 - 15:59 </p>
<p class="controls tip">
<a class="quote" title="Citar" href="javascript:void(0);"><span>Citar</span></a> </p>
</div>
<div class="comment-body clearfix" id="comment-body-5482">
<div class="avatar"><img alt='' src='http://0.gravatar.com/avatar/644a83eaae819754d3405dd812a4519b?s=64&#038;d=mm&#038;r=x' srcset='http://0.gravatar.com/avatar/644a83eaae819754d3405dd812a4519b?s=128&amp;d=mm&amp;r=x 2x' class='avatar avatar-64 photo' height='64' width='64'/></div>
<div class="comment-text"><p>C# es el mejor lenguaje para programar en .net. </p>
<p>VB.NET es un engendero del demonio! </p>
<p>Jeje</p>
</div>
<a id="comment-reply-5482"></a>
</div>
<br/><br/>
</div>
</div>
</div>
</div>
</li> 
 
<li class="comment even thread-even depth-1 with-avatar" id="comment-68807">
<div class="comment-mask regularcomment">
<div class="comment-main">
<div class="comment-wrap1">
<div class="comment-wrap2">
<div class="comment-head tiptrigger">
<p>
<a class="comment-id" href="#comment-68807">#5</a> by <b id="commentauthor-68807">BiaNamaran</b> on 28 de Marzo de 2017 - 13:09 </p>
<p class="controls tip">
<a class="quote" title="Citar" href="javascript:void(0);"><span>Citar</span></a> </p>
</div>
<div class="comment-body clearfix" id="comment-body-68807">
<div class="avatar"><img alt='' src='http://1.gravatar.com/avatar/797c6099e40dcbd3d78d0889533a8bf7?s=64&#038;d=mm&#038;r=x' srcset='http://1.gravatar.com/avatar/797c6099e40dcbd3d78d0889533a8bf7?s=128&amp;d=mm&amp;r=x 2x' class='avatar avatar-64 photo' height='64' width='64'/></div>
<div class="comment-text"><p>¿Crees que Visual Basic .NET es más potente? Más complejo sí, para ciertos proyectos (grandes y que requieran mucha carga) más capacitado, pero no diría yo que es más potente. La potencia de un lenguaje es difícil de cuantificar, pero BASIC en su sencillez era enormemente potente por eso, porque era sencillo, de la misma forma que C lo era -y es- no por la complicación del lenguaje en sí, sino por permitir programación a tan bajo nivel que otros no podían alcanzar. Java es potente porque te permite trabajar con muchos entornos gracias a sus máquinas virtuales (en todo lo demás, está por detrás de C). Ahora bien, decir que VBNET es más potente que BASIC&#8230;. ¿por qué? ¿Porque el IDE es más complejo? ¿Porque la RAD también se usa en C#? ¿Porque tiene la desventaja -yo no lo llamaría ventaja- de su infumable framework?</p>
<p>Lejos de mí contradecirte -además, tú me das mil vueltas en esto-, pero BASIC era muy potente porque con la sencillez que tiene podías hacer proyectos enormes con muy poca inversión en desarrollo. De hecho en tiempos de VBScrip, algunos programas los hacía en script usando VB porque con Java era odioso hacerlo, y no es que Java no pudiera, pero requería tal complicación y tiempo de depuración que agotaban mi paciencia.</p>
<p>Obviamente un Lamborghini es más potente que un Seat Ibiza, pero ¿para qué? Claro, si estás en un circuito es mejor el Lambo, pero para el día a día y para llevar a los críos al colegio e irse uno al trabajo, mejor comprarse el Ibiza. Será menos potente, pero más eficiente. </p>
<p>Microsoft se vio obligada a hacer ese mal-invento del VBNET por una única razón: para obligar a usar su framework. No tenían otra salida. ¿Y como lo hicieron? Pues como hacen las cosas desde hace ya bastantes años: en plan chapuza.</p>
</div>
<a id="comment-reply-68807"></a>
</div>
<br/><br/>
</div>
</div>
</div>
</div>
</li> 
 
<li class="comment byuser comment-author-guti bypostauthor odd alt thread-odd thread-alt depth-1 with-avatar" id="comment-68808">
<div class="comment-mask admincomment">
<div class="comment-main">
<div class="comment-wrap1">
<div class="comment-wrap2">
<div class="comment-head tiptrigger">
<p>
<a class="comment-id" href="#comment-68808">#6</a> by <span class="with-tooltip"><a class="comment-author" id="commentauthor-68808" href="http://www.javiergutierrezchamorro.com">Javier Gutiérrez Chamorro (Guti)</a></span> on 28 de Marzo de 2017 - 15:12 </p>
<p class="controls tip">
<a class="quote" title="Citar" href="javascript:void(0);"><span>Citar</span></a> </p>
</div>
<div class="comment-body clearfix" id="comment-body-68808">
<div class="avatar"><img alt='' src='http://0.gravatar.com/avatar/fef7e7ec3b5cabd126f26228e7ae8022?s=64&#038;d=mm&#038;r=x' srcset='http://0.gravatar.com/avatar/fef7e7ec3b5cabd126f26228e7ae8022?s=128&amp;d=mm&amp;r=x 2x' class='avatar avatar-64 photo' height='64' width='64'/></div>
<div class="comment-text"><p>Me quedo con tu comparativa final <b>BiaNamaran</b>. BASIC es un Seat Ibiza, y VB.NET, no diría que es un Lamborghini, pero podría ser un Seat León TDI.</p>
<p>Claro que hay gente como PowerBASIC, que vendrían a hacer algo como un Ibiza Cupra. No es que lo necesites a diario, pero está bien tenerlo.</p>
<p>Aunque me gusta mucho VB, le veo varias carencias. La primera es el manejo de errores con On Error, que lo hace muy tedioso. La segunda son las cosas raras de compatiblidad, por ejemplo que un Integer sea de 16 bits, y debamos usar Long para todo, o que no sea OOP. En eso me gusta C/C++. Te permite programar proceduralmente, o con objetos, tu elijes.</p>
<p>VB.NET, como lenguaje es mucho más moderno, como Framework, hace muchas cosas. Lo malo, es que es poco eficiente, y que no te permite empezar a codificar de manera rápida. Algo que VB permitía. Hacías el prototipo con el diseñador de formularios, escribías algo de código, y en unos minutos tenías algo.</p>
</div>
<a id="comment-reply-68808"></a>
</div>
<br/><br/>
</div>
</div>
</div>
</div>
</li> 
</ul>
<div id="respond">
<script type="text/javascript">
       function validatecomment(form){
         if(form.author.value == ('' || 'Your name (required)')){
           alert('Please enter your name');
           return false;
         }
         if(form.email.value == ('' || 'Your e-mail (required, will not be published)')){
           alert('Please enter your email address');
           return false;
         }
         if(form.comment.value == ('' || 'Type your comment here')){
           alert('Please type a comment');
           return false;
         }
         if(form.url.value == ('' || 'Your website')){
           form.url.value = '';
           return true;
         }
       }
      </script>
<div id="adsadpv49481"></div><script type="text/javascript">var adpv_client="49481"; var adpv_width=300; var adpv_height=250; var adpv_container_id="adsadpv49481";</script><script type="text/javascript" src="http://ads.adpv.com/ads.js"></script> <form action="http://www.javiergutierrezchamorro.com/wp-comments-post.php" method="post" id="commentform" onsubmit="return validatecomment(this);">
<div class="cancel-comment-reply"><a rel="nofollow" id="cancel-comment-reply-link" href="/visual-basic-net-no-es-basic/503#respond" style="display:none;">Cancelar Respuesta</a></div> <div id="author_info">
<div class="row">
<input type="text" name="author" id="author" required class="textfield required" size="34" tabindex="1" value="" placeholder="Your name (required)"/>
</div>
<div class="row">
<input type="email" name="email" id="email" required class="textfield required" value="" placeholder="Your e-mail (required, will not be published)" size="60" tabindex="2"/>
</div>
<div class="row">
<input type="url" name="url" id="url" class="textfield" value="" placeholder="Your website" size="60" tabindex="3"/>
</div>
</div>
 
<div class="row">
<textarea name="comment" id="comment" required class="required" tabindex="4" rows="8" cols="60" placeholder="Type your comment here"></textarea>
<input type='hidden' name='comment_post_ID' value='503' id='comment_post_ID'/>
<input type='hidden' name='comment_parent' id='comment_parent' value='0'/>
</div>
 
<div id="submitbox" class="left">
<input name="submit" type="submit" id="submit" class="button" tabindex="5" value="Enviar Comentario"/>
<input type="hidden" name="formInput"/>
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0221450fb4"/></p> <p class="antispam-group antispam-group-q" style="clear: both;">
<label>Current <a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="c9b0ac89bb">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script> <span class="required">*</span></label>
<input type="hidden" name="antspm-a" class="antispam-control antispam-control-a" value="2017"/>
<input type="text" name="antspm-q" class="antispam-control antispam-control-q" value="4.3" autocomplete="off"/>
</p>
<p class="antispam-group antispam-group-e" style="display: none;">
<label>Leave this field empty</label>
<input type="text" name="antspm-e-email-url-website" class="antispam-control antispam-control-e" value="" autocomplete="off"/>
</p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Recibir un email con los siguientes comentarios a esta entrada.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Recibir un email con cada nueva entrada.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="56"/></p> </div>
</form>
</div>
 
</div>
</div>
 
 
<div class="col2">
<ul id="sidebar">
<li class="block widget widget_categories" id="categories-3"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Categorías</span></h4></div> <ul>
<li class="cat-item cat-item-13"><a href="http://www.javiergutierrezchamorro.com/category/actualidad" title="Actualidad, última hora, noticias y novedades">Actualidad</a> (32)
</li>
<li class="cat-item cat-item-510"><a href="http://www.javiergutierrezchamorro.com/category/afeitado" title="Afeitado clásico, convencional, lociones, jabones, brochas, maquinillas, cuchillas, cuidado personal y otros productos">Afeitado</a> (28)
</li>
<li class="cat-item cat-item-514"><a href="http://www.javiergutierrezchamorro.com/category/amigos" title="Amigos, colaboradores, guestposting, artículos cedidos, post patrocinados">Amigos</a> (28)
</li>
<li class="cat-item cat-item-12"><a href="http://www.javiergutierrezchamorro.com/category/arte" title="Pintura, escultura, fotografía, modelos, multimedia y otras disciplinas artísticas en general">Arte</a> (81)
</li>
<li class="cat-item cat-item-1"><a href="http://www.javiergutierrezchamorro.com/category/ciencia" title="Ciencias formales y ciencias naturales">Ciencia</a> (80)
</li>
<li class="cat-item cat-item-2"><a href="http://www.javiergutierrezchamorro.com/category/cine" title="Películas, cine, directores, guionistas, actores, actrices, estrenos, celebrities">Cine</a> (178)
</li>
<li class="cat-item cat-item-3"><a href="http://www.javiergutierrezchamorro.com/category/coches" title="Automóviles, motocicletas, tunning, Fórmula 1, Fórmula-E, rallys y otros deportes del motor">Coches</a> (234)
</li>
<li class="cat-item cat-item-511"><a href="http://www.javiergutierrezchamorro.com/category/escritura" title="Elementos y de escritura, plumas estilográficas, grafos, artículos de escritorio, cartuchos, tintas, conversores a émbolo y otros accesorios">Escritura</a> (29)
</li>
<li class="cat-item cat-item-4"><a href="http://www.javiergutierrezchamorro.com/category/filosofia" title="Filosofía, humanismo, y otros pensamientos  y pensadores">Filosofía</a> (19)
</li>
<li class="cat-item cat-item-513"><a href="http://www.javiergutierrezchamorro.com/category/hogar" title="Decoración, menaje, ropa de cama, y útiles para la casa">Hogar</a> (37)
</li>
<li class="cat-item cat-item-14"><a href="http://www.javiergutierrezchamorro.com/category/humor" title="Chistes, gracias, tonterías variadas, y humor en general">Humor</a> (82)
</li>
<li class="cat-item cat-item-5"><a href="http://www.javiergutierrezchamorro.com/category/informatica" title="Informática, tecnología, TIC, i+D+i, ...">Informática</a> (1.393)
<ul class='children'>
<li class="cat-item cat-item-507"><a href="http://www.javiergutierrezchamorro.com/category/informatica/hardware" title="Hardware de consumo y empresarial. Electrónica y gadgets">Hardware</a> (128)
</li>
<li class="cat-item cat-item-506"><a href="http://www.javiergutierrezchamorro.com/category/informatica/internet" title="Internet, portales, servicios, P2P, descargas, ...">Internet</a> (636)
</li>
<li class="cat-item cat-item-504"><a href="http://www.javiergutierrezchamorro.com/category/informatica/juegos" title="Juegos de ordenador, PC, consolas, arcade, online y móviles">Juegos</a> (109)
</li>
<li class="cat-item cat-item-501"><a href="http://www.javiergutierrezchamorro.com/category/informatica/noticias" title="Novedades, presentaciones, rumores, noticias, y lanzamientos">Noticias</a> (115)
</li>
<li class="cat-item cat-item-502"><a href="http://www.javiergutierrezchamorro.com/category/informatica/programacion" title="Programación general, plataformas (Windows, DOS, Linux, recreativas, móviles, web, ...), y lenguajes de programación (C/C++, PHP, Javascript, HTML, Flash, BASIC, Pascal, ...)">Programación</a> (480)
</li>
<li class="cat-item cat-item-505"><a href="http://www.javiergutierrezchamorro.com/category/informatica/retro" title="Retroinformática y vintage, desde el inicio de la informática">Retro</a> (273)
</li>
<li class="cat-item cat-item-503"><a href="http://www.javiergutierrezchamorro.com/category/informatica/software" title="Análisis de software y aplicaciones y de nuevas versiones o actualizaciones">Software</a> (772)
</li>
</ul>
</li>
<li class="cat-item cat-item-512"><a href="http://www.javiergutierrezchamorro.com/category/juguetes" title="Muñecos, figuras de acción, slot, maquetas, modelismo, rol, juegos de mesa y otros juegos juguetes">Juguetes</a> (17)
</li>
<li class="cat-item cat-item-6"><a href="http://www.javiergutierrezchamorro.com/category/libros" title="Libros, autores, escritores, novelas, cuentos, antologías y literatura en general">Libros</a> (91)
</li>
<li class="cat-item cat-item-509"><a href="http://www.javiergutierrezchamorro.com/category/moda" title="Moda, textil, calzado y complementos de vestir para hombre y mujer">Moda</a> (70)
</li>
<li class="cat-item cat-item-7"><a href="http://www.javiergutierrezchamorro.com/category/musica" title="Grupos, bandas, solistas, compositores, productores, remezclas, singles, discos, vinilos LP, CD, videoclips, DJ, conciertos, canciones, temas, cortes, ...">Música</a> (62)
</li>
<li class="cat-item cat-item-8"><a href="http://www.javiergutierrezchamorro.com/category/personal" title="Íntimo y personal, no obstante con ciertos límites">Personal</a> (218)
</li>
<li class="cat-item cat-item-9"><a href="http://www.javiergutierrezchamorro.com/category/reflexiones" title="Pensamientos, reflexiones y análisis más o menos personales que desean ser compartidos">Reflexiones</a> (136)
</li>
<li class="cat-item cat-item-508"><a href="http://www.javiergutierrezchamorro.com/category/relojes" title="Horología, guardatiempos, relojes de pared, de pulsera, de bolsillo, de mesa, analógicos, digitales, de cuarzo, mecánicos, japoneses, suizos, chinos, modernos, antiguos, ...">Relojes</a> (164)
</li>
<li class="cat-item cat-item-10"><a href="http://www.javiergutierrezchamorro.com/category/television" title="Programación, series de TV, documentales, presentadores, concursos y todo lo que pueda salir de la caja tonta">Televisión</a> (160)
</li>
<li class="cat-item cat-item-11"><a href="http://www.javiergutierrezchamorro.com/category/varios" title="Cajón de sastre donde entra todo lo que no cabe en otras categorías, o que no tenga una temática clara">Varios</a> (212)
</li>
</ul>
</div></div></div></div></div></div> </div></li><li class="block widget widget_search" id="search-3"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Búsqueda</span></h4></div>
 
<form method="get" id="searchform" action="http://www.javiergutierrezchamorro.com/">
<input type="search" name="s" id="searchbox" required class="searchfield" value="" placeholder="Buscar"/>
<input type="submit" value="Go" class="searchbutton"/>
</form>
 </div></div></div></div></div></div> </div></li><li class="block widget widget_advancedrandomposts" id="advancedrandomposts-4"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Entrada aleatoria</span></h4></div><ul class="advanced-random-posts"><li><a href="http://www.javiergutierrezchamorro.com/despertador-vostok-m801-1/3033" title="Despertador Vostok M801.1">Despertador Vostok M801.1</a></li>
</ul></div></div></div></div></div></div> </div></li><li class="block widget widget_recent_comments" id="recent-comments-3"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Últimos comentarios</span></h4></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">julian</span> en <a href="http://www.javiergutierrezchamorro.com/las-viejas-glorias-jhayber/2987#comment-68810">Las viejas glorias de J&#8217;hayber</a></li><li class="recentcomments"><span class="comment-author-link">julian</span> en <a href="http://www.javiergutierrezchamorro.com/las-viejas-glorias-jhayber/2987#comment-68809">Las viejas glorias de J&#8217;hayber</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.javiergutierrezchamorro.com' rel='external nofollow' class='url'>Javier Gutiérrez Chamorro (Guti)</a></span> en <a href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503#comment-68808">Visual Basic .NET no es Basic</a></li><li class="recentcomments"><span class="comment-author-link">BiaNamaran</span> en <a href="http://www.javiergutierrezchamorro.com/visual-basic-net-no-es-basic/503#comment-68807">Visual Basic .NET no es Basic</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.javiergutierrezchamorro.com' rel='external nofollow' class='url'>Javier Gutiérrez Chamorro (Guti)</a></span> en <a href="http://www.javiergutierrezchamorro.com/despertador-vostok-m801-1/3033#comment-68806">Despertador Vostok M801.1</a></li><li class="recentcomments"><span class="comment-author-link">BiaNamaran</span> en <a href="http://www.javiergutierrezchamorro.com/despertador-vostok-m801-1/3033#comment-68805">Despertador Vostok M801.1</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.javiergutierrezchamorro.com' rel='external nofollow' class='url'>Javier Gutiérrez Chamorro (Guti)</a></span> en <a href="http://www.javiergutierrezchamorro.com/las-viejas-glorias-jhayber/2987#comment-68804">Las viejas glorias de J&#8217;hayber</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.javiergutierrezchamorro.com' rel='external nofollow' class='url'>Javier Gutiérrez Chamorro (Guti)</a></span> en <a href="http://www.javiergutierrezchamorro.com/que-precision-tienen-los-relojes/1997#comment-68803">¿Qué precisión tienen los relojes?</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.javiergutierrezchamorro.com' rel='external nofollow' class='url'>Javier Gutiérrez Chamorro (Guti)</a></span> en <a href="http://www.javiergutierrezchamorro.com/sieve-powerbasic-console-compiler-6/2991#comment-68802">Sieve en PowerBASIC Console Compiler 6</a></li><li class="recentcomments"><span class="comment-author-link">jose sanchez</span> en <a href="http://www.javiergutierrezchamorro.com/que-precision-tienen-los-relojes/1997#comment-68801">¿Qué precisión tienen los relojes?</a></li></ul></div></div></div></div></div></div> </div></li><li class="block widget widget_text" id="text-2"><div class="box"> <div class="wrapleft"><div class="wrapright"><div class="tr"><div class="bl"><div class="tl"><div class="br the-content"><div class="titlewrap"><h4><span>Enlaces</span></h4></div> <div class="textwidget"><p><a href="http://www.javiergutierrezchamorro.com">Principal</a><br/>
<a href="http://www.javiergutierrezchamorro.com/contacta-conmigo">Contacta conmigo</a></p>
<p>Generales<br/>
<a href="http://www.javiergutierrezchamorro.com/acerca-del-autor">Acerca del autor</a><br/>
<a href="http://www.javiergutierrezchamorro.com/anunciarse">Anunciarse aquí</a><br/>
<a href="http://nikkhokkho.sourceforge.net" target="_blank">Mi software</a><br/>
<a href="https://www.amazon.es/s/ref=dp_byline_sr_ebooks_1/?tag=gutibitacor0c-21&search-alias=digital-text&field-author=Javier+Gutiérrez+Chamorro" target="_blank">Mis libros en Amazon</a><br/>
<a href="http://www.facebook.com/javier.gutierrez.chamorro.bitacora" target="_blank">Perfil en Facebook</a><br/>
<a href="http://twitter.com/bitacoraguti" target="_blank">Sígueme en Twitter</a><br/>
<a href="http://es.linkedin.com/in/javiergutierrezchamorro" target="_blank">Perfil en Linkedin</a><br/>
<a href="http://es.youtube.com/nikkho" target="_blank">Videos en Youtube</a><br/>
<a href="http://www.javiergutierrezchamorro.com/date/2004">Hemeroteca</a><br/>
<a href="http://translate.google.com/translate?u=http%3A%2F%2Fwww.javiergutierrezchamorro.com&langpair=es%7Cen&hl=es" target="_blank">Translate to english</a><br/>
<a href="http://www.google.com/gwt/n?u=http%3A%2F%2Fwww.javiergutierrezchamorro.com" target="_blank">Versión WAP</a></p>
<p>Otras bitácoras<br/>
<a href="http://bianamaran.blogspot.com" target="_blank">Bia Namaran</a><br/>
<a href="http://www.polimalo.com" target="_blank">David (Polimalo)</a><br/>
<a href="http://www.duraderos.com" target="_blank">Duraderos</a><br/>
<a href="http://www.landingshort.com" target="_blank">Joan (Landing Short)</a><br/>
<a href="http://estilograficabcn.blogspot.com" target="_blank">José (Amics de l'estilogràfica)</a><br/>
<a href="http://www.planetacodigo.com" target="_blank">Planeta Código</a><br/>
<a href="http://revistaordenadores.blogspot.com" target="_blank">Revista Ordenadores</a><br/>
<a href="http://www.revistarelojes.com" target="_blank">Revista Relojes</a><br/>
<a href="http://www.zonacasio.com" target="_blank">Zona Casio</a></p>
<p>Otros</p>
</div>
</div></div></div></div></div></div> </div></li> <li class="block">
<div class="box">
<div class="titlewrap"><h4><span>Otros</span></h4></div>
<div class="wrapleft">
<div class="wrapright">
<div class="tr">
<div class="bl">
<div class="tl">
<div class="br the-content">
<ul>
<br/><br/><center>
 
 
 
 
</center>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
</ul>
</div>
 
</div>
</div>
</div>
 
</div>
</div>
 
 
<div id="footer">
 
<div class="block-content">
<div class="copyright">
<p>
<a href="http://www.creativecommons.org/licenses/by/4.0/deed.es" target="_blank">Creative Commons</a> (cc) 2004-2017 Javier Guti&eacute;rrez Chamorro (Guti) - P&aacute;gina generada en 0,630 segundos
</p>
</div>
</div>
 
</div>
 
</div>
 
<script type="text/javascript">
  /* <![CDATA[ */
    var isIE6 = false; /* <- do not change! */
    var isIE = false; /* <- do not change! */
    var lightbox = false;/* <- do not change! */
  /* ]]> */
  </script>
<!--[if lte IE 6]> <script type="text/javascript"> isIE6 = true; isIE = true; </script> <![endif]-->
<!--[if gte IE 7]> <script type="text/javascript"> isIE = true; </script> <![endif]-->
 
<div class="cdp-cookies-alerta  cdp-cookies-layout-ventana cdp-cookies-pos-inferior cdp-cookies-textos-izq cdp-cookies-tema-gris">
<div class="cdp-cookies-texto">
<h4 style="font-size:15px !important;line-height:15px !important">Uso de cookies</h4><p style="font-size:12px !important;line-height:12px !important">Esta web utiliza cookies para mejorar la mejor experiencia de usuario. Si continúas navegando estás dandos tu consentimiento para la aceptación de las mismas y la aceptación de la <a href="http://www.javiergutierrezchamorro.com/politica-de-cookies" style="font-size:12px !important;line-height:12px !important">política de cookies</a>, pincha el enlace para más información.</p>
<a href="javascript:;" class="cdp-cookies-boton-cerrar">CERRAR</a>
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.javiergutierrezchamorro.com\/visual-basic-net-no-es-basic\/503":503};
	</script>
<div id="sharing_email" style="display: none;">
<form action="/visual-basic-net-no-es-basic/503" method="post">
<label for="target_email">Enviar a dirección de correo electrónico</label>
<input type="email" name="target_email" id="target_email" value=""/>
<label for="source_name">Su Nombre</label>
<input type="text" name="source_name" id="source_name" value=""/>
<label for="source_email">Tu dirección de correo electrónico</label>
<input type="email" name="source_email" id="source_email" value=""/>
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="Este campo sirve de validación y no debería cambiarse"/>
<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
<img style="float: right; display: none" class="loading" src="http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif?x34527" alt="loading" width="16" height="16"/>
<input type="submit" value="Enviar correo electrónico" class="sharing_send"/>
<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancelar</a>
<div class="errors errors-1" style="display: none;">
La entrada no fue enviada. ¡Comprueba tus direcciones de correo electrónico! </div>
<div class="errors errors-2" style="display: none;">
Error en la comprobación de email. Por favor, vuelve a intentarlo </div>
<div class="errors errors-3" style="display: none;">
Lo sentimos, tu blog no puede compartir entradas por correo electrónico. </div>
</form>
</div>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/anti-spam/js/anti-spam-4.3.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201713'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"http:\/\/www.javiergutierrezchamorro.com\/wp-content\/plugins\/wp-postratings","ajax_url":"http:\/\/www.javiergutierrezchamorro.com\/wp-admin\/admin-ajax.php","text_wait":"Por favor, valora solo 1 elemento cada vez.","image":"stars","image_ext":"gif","max":"5","show_loading":"0","show_fading":"0","custom":"0"};
var ratings_mouseover_image=new Image();ratings_mouseover_image.src="http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/images/stars/rating_over.gif?x34527";;
/* ]]> */
</script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.84'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var viewsCacheL10n = {"admin_ajax_url":"http:\/\/www.javiergutierrezchamorro.com\/wp-admin\/admin-ajax.php","post_id":"503"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-postviews/postviews-cache.js?ver=1.68'></script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/wp-syntax/js/wp-syntax.js?ver=1.1'></script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.javiergutierrezchamorro.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.7.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201713.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.7.1',blog:'115063527',post:'503',tz:'2',srv:'www.javiergutierrezchamorro.com'} ]);
	_stq.push([ 'clickTrackerInit', '115063527', '503' ]);
</script>
<script type="text/javascript">
	var aLinks = document.getElementsByTagName('a');
	var iLinksLen = aLinks.length;
	
	for (var iLink = 0; iLink < iLinksLen; iLink++)
	{
		var sLink = aLinks[iLink].href;
		//console.log(sLink);
		
		//eBay affiliates
		if ((sLink.indexOf('rover.ebay.com') !== -1) && (sLink.indexOf('pub=5575153231') === -1))
		{
			sLink = ParamReplace(sLink, 'pub', '5575153231');	
		}
		//eBay.es
		else if ((sLink.indexOf('ebay.es') !== -1) && (sLink.indexOf('pub=5575153231') === -1))
		{
			sLink = '//rover.ebay.com/rover/1/1185-53479-19255-0/1?ff3=4&pub=5575153231&toolid=10001&campid=5337807603&customid=&mpre=' + escape(sLink);
		}
		//eBay.com
		else if ((sLink.indexOf('ebay.com') !== -1) && (sLink.indexOf('pub=5575153231') === -1))
		{
			sLink = '//rover.ebay.com/rover/1/711-53200-19255-0/1?ff3=4&pub=5575153231&toolid=10001&campid=5337807603&customid=&mpre=' + escape(sLink);
		}
		//Amazon.es
		else if ((sLink.indexOf('amazon.es') !== -1) && (sLink.indexOf('tag=gutibitacor0c-21') === -1))
		{
			sLink = ParamReplace(sLink, 'tag', 'gutibitacor0c-21');
		}
		//Meranom.com
		else if ((sLink.indexOf('meranom.com') !== -1) && (sLink.indexOf('tracking=54a2563b3980a') === -1))
		{
			sLink = ParamReplace(sLink, 'tracking', '54a2563b3980a');
		}
		//Dreamhost.com
		else if ((sLink.indexOf('dreamhost.com/r.cgi') !== -1) && (sLink.indexOf('1561838') === -1))
		{
			sLink = ParamReplace(sLink, '', '1561838');
		}
		//DigitalOcean.com
		else if ((sLink.indexOf('dreamhost.com/r.cgi') !== -1) && (sLink.indexOf('bcae4f3b87e0') === -1))
		{
			sLink = ParamReplace(sLink, 'refcode', 'bcae4f3b87e0');
		}
		aLinks[iLink].href = sLink;
	}
	
	
	
	function ParamReplace(uri, key, value)
	{
		var re = new RegExp("([?|&])" + key + "=.*?(&|#|$)", "i");
		if (uri.match(re))
		{
			return uri.replace(re, '$1' + key + "=" + value + '$2');
		}
		else
		{
			var hash =  '';
			if( uri.indexOf('#') !== -1 )
			{
				hash = uri.replace(/.*#/, '#');
				uri = uri.replace(/#.*/, '');
			}
			var separator = uri.indexOf('?') !== -1 ? "&" : "?";    
			return uri + separator + key + "=" + value + hash;
		}
	}
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-57056-1', 'auto');
	ga('send', 'pageview');
</script>
</body>
</html>
 